I keep getting Error 601: no corresponding activity found

I am making an application for a project and one of its functions is that users can tap a button to see what their current location is, besides that they can choose some predefined street addresses to show as well. I keep getting this error and I do not know where the problem is. Please help, and thanks in advance.


Both the lower and upper Block works on an Android 8.1 tablet to post a location and a Marker pin.

The lower code works on the stock emulator; the upper code will not (because the emulator does not have gps hardware).

You may be getting error 601 because you are:

  • attempting to use the gps with an emulator
  • the device you use might not have gps hardware; not all tablets have a gps receiver
  • the gps might not have a satellite fix when you attempt to use the ActivityStarter with your gps. Wait about 60 seconds and try again or go outside to test your app.
  • the reported CurrentAddress is 'No address available' ... in that instance the ActivityStarter can not display an address. Be aware, the address comes from Google's database, if you don't have a WIFI or network connection, you can not access it. Also, not every position on the globe has an address associated with it.'

Are you testing on an Android or an iOS device? The code might not work with iOs.

1 Like

Hello and thank you for your reply.
I am using MEmu emulator as i am using an iOS device and cannot really use my apps on it. If i were to use android device, it would work right?

One more question is, i read some documentation and it says that I need to use URL decoding to replace spaces and commas, do i need to do that, or i can just enter the address for lets say Louvre Museum

I tried it on the android device, and now it works, prompts me to open google maps, but when i press the MyLoc button (my location) google maps says that they could not find the adress even though i have good wifi connection and i live in a capital.

I don't have an MEmu. The lower code will work with the aiStarter emulator; I don't know about the MEmu. The code I posted will work on any Android.

No you do not need to use escape characters, if it enter Louvre Museum in the Text Block, a map shows in Paris :slight_smile: using the code I posted.

1 Like

I am so sorry for wasting your time, I found a problem, google maps was not allowed by some chance on my device. Now everything works perfectly. Thank you so much Steve! How do i give you a vouche?

1 Like

If you have apps not working on iOS and you can easily reproduce the issues, please let us know what the problems are so we can work on fixing them.