I can't send data to Google Spreadsheet. I have tried all solutions

I have an application wich will be a kind of "term paper" for my college.
Everything was working. But suddenly I can no longer send the data from my application to a Google spreadsheet. It suddenly stopped working, I didn't make any changes to any properties in App Inventor, Google Sheet or Apps Script. I have already reviewed all the permissions on the spreadsheet, I have already updated the deployment in Apps Script, but it didn't work. I put in a response code. The "200" code appears, which means that the Post method worked. I am attaching all possible information so that you can help me.

PS*: My project has information in Portuguese, because it is my native language.

   Thanks in advance.

Google Apps Script.txt (558 Bytes)


Thank you very much for helping me and answering me so quickly, TIMAI2. I figured that having the response code 200 would mean that the Post method worked. But I will try to look at the content of the response. I will post the results here. Best regards.

Yes but:

The HTTP 200 OK success status response code indicates that the request has succeeded. A 200 response is cacheable by default.

The meaning of a success depends on the HTTP request method:

GET: The resource has been fetched and is transmitted in the message body.
POST: The resource describing the result of the action is transmitted in the message body

It doesn't necessarily mean that the script performed in the manner you expected.....:wink:


Got it, TIMAI2. Thanks again. I got the "success" answer in the Web gottext block. But unfortunately, my spreadsheet didnt receive the data coming from my application. I don't understand. It was working and it stopped working. I didn't change anything. Is there an error in my script?

I want to thank TIMAI2 and everyone on this forum. I have redone my data submission block. Now it is working. The image of the working block is attached. Thank you all very much.
Best Regards.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.