I can't see the folder ASD on my mobile

Using ?

and did you only just now create access ?

Android 13 fixed the loophole.

Among others, for example:

Amazing, this is the only app which works.
Features will be limited though as developer is using DocumentFile instead of DocumentsContract.

I just tried these steps again to open other apps inside /Android/data and it still worked for me on Samsung Galaxy A54 running Android 13


To what extent?

Copy/Move not supported.
Creating files and folders may or may not be possible.
DocumentFile is known to be slower while listing files.
You will be able to see content inside /data and /obb folders but may miss some basic file operations.

I've no problem dragging (moving) a file from one ASD to another.

Why did I say this?

@Anke what you are seeing is AOSP's Files app which is hidden on all phones.

I don't understand what you're trying to tell me.

Screenshots shown here are of Files app which is opened by FV File Manager to let user access data and obb folders.
In short, this app also can't access those dirs on its own. Instead it launches Files app which is hidden from user and can be opened only through intent.

Yes and ...? Anyway, I can easily move a file from one ASD to another (as already said):

It explains why Total Commander or other file explorers can't access those dirs.

Obviously, you can do all file operations with Files app. Android restrictions don't apply on it.


This might be useful, not tested any of it yet:

This one seems to work


can copy from Companion app /files but not to....

It's been so long and I still haven't been able to see the files in the folder

Has anyone succeeded?
Android 13 , Samsung Galajy A52s

it does not look like you read this thread from the beginning to find several answers... for example try Total Commander


This one works for me

I have read from the beginning, I have loaded total comander and I have uploaded screenshots at the beginning of the topic.

Please look at it and tell me where I'm doing wrong or why it's not showing me the contents of the folder.

Follow my steps I can't see the folder ASD on my mobile - #14 by Taifun and for test purposes try another directory inside /Android/data, for example one of your own projects, which start with appinventor.ai_