I can't open the application I'm creating


We have been creating an application in class and now it does not let us open it. The application slows down the account in which the application is and we cannot do anything. Everything has happened overnight. We are not done yet but we have invested a lot of time in the project … Could it be because the application has many pages?

I have also tried to download the .aia file of the application and upload it to another account but the same thing happens …

Thank you very much for your help

Yes, if you have more than 10 Screens or very many Layouts, a Project may refuse to load.

Did you save an aia copy of your Project earlier? If you have an aia copy made earlier, that copy may load where your current Project will not.

It refuses to open? Do you see any error messages or it just refuses to load?

If the problem is that your app is too large to be handled by the main AI2 server, you might be able to load the aia on the alternative server http://code.appinventor.mit.edu/ and fix your probable screen issues.

1 Like

how many pages do you have?
see also Building Apps with Many Screens

Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

1 Like

Thank you very much for your responses.

I don’t see any error message, it just doesn’t load and the project selection screen is locked.

I tried to open it at http://code.appinventor.mit.edu/ and although I can capture the .aia file, then it does not open and the project selection page is also blocked.

Can I try it some other way? If anyone wants to submit it, I can send the .aia file by email …

We have worked a lot in class and would not like to lose what has been done so far …

How big is your aia? Do you use large assets? You can pm me your aia if you want so i can take a look.

We have 63 screens, they are too many … but so far it has left us to work and not giving us much …

The other day it was blocked and we could not do anything. It’s a shame because it’s the class project and we’ve worked hard on it …

I send it to you?

Thank you very much for your attention

I took a look at the aia. You have 63 (real) screen. That cannot work, I removed 4 screens and the aia is loading.

1 Like

I removed these:

So open your aia with winZip (winRar), remove these screens and rebuild them (and others) as virtual screens.


That’s what I’ll do. Thank you very much for your help

You should also adjust the images with regard to the size / resolution actually required, eg:


1- pls i can't open my project online i tried download the offline is telling me is not compatible.
2- i try another process after i downloaded and install it in my phone, the app keep displaying "App not installed"
blocks admin page

blocks Splash screen

A guess is your CLOCK5.ICO file might not be compatible and is an issue. Delete it or change it to a png or jpg file.

If that does not work, post your Blocks please and tell us how many Blocks are in your Project. Someone might have another idea.

Ok. Appreciated

Everything is working normally. But in a button close, I just want to change it to "close application", instead of "close screen"