I can't download my blocks as image at all!

I really can't download blocks as images. I right clicked in the blocks editor, and clicked in the "Download blocks as image" option, but nothing happens. I try again and again but nothing happens when i click the item
Note: I am using Firefox on linux

1 Like

I just tried with Firefox on linux and it works for me. With distro are you using and what FireFox version.

I have Ubuntu 20.04.1 LTS with FF 84.0.2 (64-bit)

I am on Linux Mint 20.0 (August'20, maximum is 20.1 Jan'21), Ubuntu-based.
Firefox version is 84.0.2

In this gif it looks like nothing happens but look at the blue arrow on the left. Is this also what you see when you click Download Blocks as image?

no, nothing happens at all. The box even doesn't disappears and the blue arrow doesn't appears. the only reason i have a blue arrow is that i downloaded it as .aia to help in a topic, but images are better once there is possible to see them without downloading and uploading them...

You mean the contextmenu?

the menu which appears when we right click

made this screenshot while clicking. it just reacts as i hasn't clicked, just holden the mouse over the menu

Does it work when you use another browser? Could you have an add-on in FF that prohibits the downloading of the image?

I don't have any add-on which does this, and my computer only has firefox installed.
Linux mint uses firefox as default browser

Could you install another another browser and try?

not actually.

Check Anti Virus not interfering ?

linux doesn't needs antivirus. i don't hava any antivirus.

Did it ever work?

once, but not always. It worked just once but i think it was in kodular. All other times i had no success both in kodular and in app inventor

could you go to preferences and look for this

Can you confirm that the "Always ask you where to save files" is checked and that you have "PNG image -> Save File".

You can click on Save File and change it to "Always Ask".

Can you report back what happens.

same thing happens

What are your settings?

i have tried with both