I am not able to download the apk file. When it is 100%, it doesnt do anything and just be 100%. What should I do?

Did you wait for some time

Yes for even 1 hour

Try using different browsers because certain browser like Internet Explorer don't work well with App Inventor. I you are using Chrome, then try using Mozilla because I encountered the exact same problem when I tried Kodular. Try switching browsers it will surely work.

I tried from each browser. Microsoft edge, chrome and mozirella

It might also be a problem with the build servers

He already tried Mozilla Firefox.

Oops my bad :sweat_smile:

You should tell more about your project. Size of assets, extensions used, etc etc.

I used 3 extensions i.e. look, countryInfo and slider.
And all are the normal features. I have used some images and videos normally.

What do you mean by "normally". Since especially videos can be really big this could cause a problem.

yes videos are of 2 mb each and images are in kbs

How big is your aia? Remove one of the videos and see if it works then. You will have to try and see if it works for you.

1 Like

How big is the aia?

aia is 29 mb

Try to remove 1 video and build ...
EDIT: Oh, @Peter already said this. Sorry!

1 Like

See also here:

How should I download android keystore?

What does this have to do with your problem?


@Peter told me to download it so I asked once...