Huawei p30 lite the texttospeeck does not work

When I run a small program where text should be read, texttospeech doesn't work.
How can the problem be solved?

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select "Download Blocks as Image". You might want to use an image editor to crop etc. if required. Then post it here in the community.


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

May be a silly question

But does your Huawei phone have Google Apps? In case you don't you may not have a Text to Speech engine installed

Hello Franco

The Huawei P30 does support Google Apps and it is not banned from Google Play Store (I have a P30 Pro). App Inventor uses which ever text-to-speech engine is the default on the device, which is often the phone manufacturer's and not Google's. So we need to see your App Inventor Blocks Franco.

Check that you have a text-to-speech engine enabled on your phone:

Settings/Accessibility features/Accessibility/Text-to-speech (the path on your phone might be slightly different).

Edit: Sorry, addressed my post to Alexander when it should be to Franco!

Hello Franco, welcome.

This example code works on all phones thru Android 8.1, it should work on you huawei. Does it?

The App Inventor 2 TextToSpeech component is very simple. The Button2.Text is 'Good Morning' .. buen dia . What does YOUR code look like?

Hi thank you I have already solved it thanks to the help of another friend of the group.
The texttospeeh just didn't work for me.
Thanks and greetings

Hi, thank you, you helped me a lot because I finally managed to make everything work
Thanks and greetings

Thanks to all.
With your help I solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.