How do you install MIT AI2 offline in Linux based OS?

Please explain me as i could not find any working method in Google

You should ask this question on a forum dedicated to your offline clone.

There isn't any MIT AI2 offline. There are third party apps that allow running a clone of App Inventor on Windows PCs. Not aware of any that will load on a Linux distribution.

A LINUX program called WINE is able to run some Windows apps on LINUX. You might install it on your Linux computer; follow the directions that comes with WINE and then cross your fingers. Google WINE Linux for a link.

Will that work; no idea. I have run many Windows apps that way on Ubuntu but never tried using one of the third party offline versions of App Inventor (and probably never will).

1 Like

https://appinventor.mit.edu/explore/ai2/linux
check this link. I have downloaded and installed, but it doesn't open

That is for the Emulator/USB

1 Like

:cry: That link shows how to access MIT App Inventor using a Linux os. It does not describe how to use Linux with an offline distribution.

oh. finally it's only possible in Windows. Thanks for your support.
I had another question?
How to change package name, as Kodular and Niotron has built in option?

No, it is eminently possible in Linux....

and please do not ask other unrelated questions, especially when you have created another topic for them...

let me know the steps, i downloaded the file and installed, but launching issue

Can we be clear as to what you want to do?

  1. Install the AI2 setup software in order to use the Emulator or connect by USB?

  2. Install and run an offline version of AI2 based upon the latest available sources?

tried all from Installing App Inventor 2 Setup on GNU/Linux
but MIT ai2 is not launching.
Tried both the methods

Maybe this is what you are looking for

What Linux are you using?

Show your installation routine (commands)

Show the output when you run AIStarter

If you just want an offline App Inventor just use

Works great on my Linux Mint.

1 Like

finally installed Linux Mint, Which file to download
image

The 7z version. Then extract that.

ok, started downloading


Which one to select to start the App Inventor

Tried all executions, but it never launches, waiting for your help

Check that the executables have their executable bit set:

chmod -x filename