How do you install emulator in Surface Pro 8?

Hi, I am facing an issue when installing MIT App Inventor, MIT_App_Inventor_Tools_30.265.0_win_setup64.exe, into my Surface Pro 8, i5 with 16Gb memory. Everytime it shows the following error at the end of installation..
Output folder: C:\Program Files\Intel\HAXM
Extract: checktool.exe
Execute: C:\Program Files\Intel\HAXM\checktool.exe --verbose
CPU vendor * GenuineIntel
Intel64 supported * Yes
VMX supported - No
VMX enabled - No
EPT supported - No
NX supported * Yes
NX enabled * Yes
Hyper-V disabled - No
OS version * Windows 10.0.22000
OS architecture * x86_64
Guest unoccupied * Yes. 0 guest(s)
Execute: cmd.exe /c type "C:\Program Files\MIT App Inventor\from-Android-SDK\extras\intel\Hardware_Accelerated_Execution_Manager\haxm_install-20221029_1651.log" > "C:\Users\manki\AppData\Local\Temp\haxm_install-20221029_1651.log"
Delete file: C:\Program Files\MIT App Inventor\from-Android-SDK\extras\intel\Hardware_Accelerated_Execution_Manager\haxm_install-20221029_1651.log

I tried to disable the Hyper-V by running the "Turn Windows features on or off" applet and but no "Hyper-V" tree on my screen.

I tried in my desktop with Win10, it's all working after activating the VMX in the BIOs setting.

Any idea?

Many thanks

Man Kit