GPS not active error

GPS is not working at all.
the AI companion app has right to access GPS, but it doesnt even shows GPS active icon in the taskbar.
I tried many settings of Location sensor component so i am sure about it.

I wrote this gps app some time ago. Check it out and if it works compare the code.
Inside it takes some time before the gps connects so you better test it outdoor!

Waar_is_de_Eiffeltoren.aia (63.8 KB)

1 Like

Please show your Blocks. There are many reasons why your gps won't respond. Here are possible reasons. We can only guess ( you did not share your app Blocks):

  • your device doesn't have gps hardware. Some tablets do not.
  • your device Settings are not set to use gps Location options.
  • you are testing your device inside a building and the device cannot receive a satellite fix (the LocationChanged event in the LocationSensor cannot fire).
  • you have coding issues. You did not share your code Blocks so how can we tell if coding is an issue?
  • did you actually receive an error message? If so, what is the exact message?

OK. So what did you try?

Did you read and do (load the examples) in Using the Location Sensor ? Do those examples work and your app does not?

Did you go outside and test your app as @Luk_Stoops recommended?

Does the Google Maps on your device work and your app does not?

Let us know what you tried and show your work and someone might provide specific advice.

I have tested both the Eiffel Tower app and AI website`s GPS test app.
seems they r working but only needs a lot of time. thanks.