GPS location is not working after samsung update

hi, i have for a couple of years a good working app that uses the gps function of my tablet. I updated today to the newest version of my samsung tablet and my app is not working well anymore. I can see that the gps updates are not working well anymore when i start up the app created in app inventor because in the past i could see the gps location icon flashing in the top corner the whole time (all the updates that i asked every 30 seconds) but now this is not working anymore while when i open other default gps apps like Maps Google, that works fine as i see the icon on the top corner popping up. Anybody who has an idea how to handle this? i tried calibrating the gps but that's not the problem. It looks like the new update is blocking one way or another the use of the gps sensor between my app and the tablet and he does this only for not standard apps like created in app inventor.

1 Like

Updated? To Android 12? Android 12 has a new feature that automatically uses the best Provider regardless of settings. That might be what is bothering you. Part of what you think is an issue might be a 'feature'.

Are you still getting location information even though the gps icon isn't displayed?

What happens if you go outside, away from your wifi? (so you device can't be connected to the wifi). Does the app used fused or gps Provider then?

Hi, updated from T5..BVD3 to T5..CVE7.
I get GPS information but much slower and much less accurate than before. When I open Maps Google or a GPS status app next to it, and i jump back and forth between the two apps then he updates quicker.
I tried with & without WIFI and indoor & outdoor without much difference.
I'm not specifying the GPS provider in the app so i assume i follow the default.

1 Like

What tablet model Leen? What did the T5..BVD3 to T5..CVE7 do? Did it update the operating system (from ? to ??) or something else.

I have a Samsung A13 which is still Android 11 (not updated yet). The apps that run on my Samsung A10 Tablet still run on the A13 but I too noticed that the gps icon doesn't appear either; however my app still works perfectly. I expect your app is working as Google intends.

On newer operating systems, they will default to the fused Provider unless you specify in code gps and lock the Provider. Android 11+ have a feature that optimizes geolocation data. See Fused Location Provider API  |  Google for Developers. If you are not happy, I think it is possible to disable Google Play Services in your device Settings (I would not do that because I don't understand all the consequences of disabling them). I expect using fused Provider gives you behavior you are not happy with. :cry:

So, what operating system was in use before the 'upgrade' and what system is it now?

i am experiencing the same problem, i did an app that allows mutual tracking between 2 devices. It worked well (I set up the app and tried it for long with two Huawei phones) until when my old Huawei fall in water and collapse and I needed to change it with a new Samsung Galaxy A23 5G. As i see, the Samsung gps location doesn't work with my app and show only an approximate position probably obteined through gsm network, while it continues to works fine with google maps.
Do you know if there's something to do for solving the problem?

1 Like


1- please read post 4

2- this code is supposed to help by forcing the app to use gps rather than the fused Provider.

3- here is a potential work around if #2 does not work for you

Did any of these help? Which one?

Perhaps @ewpatton will comment? Quality of the coordinate fix still is not as good as prior to upgrading to Android 12 and the MIT 'fix' of the issue. :cry: Google says both Coarse and Fine location permission must be provided in a single command and the Blocks don't allow that. How do you suggest coding this Evan?