Google play upload error, android:exported

and how can update the extentions

You should contact the extension developer, to ask them to update their extension to work with API 31.

its something to do with that task cog is why it the aab
won't upload to google play

sorry, I do not understand...
what about providing a list of extensions you are using?
also make sure to always use the latest versions...


here is list of extensions

and blocks

but when i upload my aab to google play store it gives me an error
but it's something to do with that task cog i'm not even using the task blocks

are you using the Background Tasks extension [3.8 A] 🥳 ?
that extension is deprecated...
if not, please provide a link to that Task extension you are using!

it looks like you are taking now about another error?
what about elaborating in a way, so others are able to understand what you are saying?

protip: if you do not use an extension in your project, what about removing it?
also what prevents you from removing an extension temporarily to test, if you still get the error?


i have the task cog with blocks like this

but i'm not using any of those blocks

Remove the Tasks extension from your project

that's the thing i can't because
the request button won't work
nore will the button for coolvibes site


but you said you were not using any of the blocks of the Tasks extension.....

i'm not see the images i posted.
that's the strange thing? i removed the task block
tested my app again to find my request button didn't work
nore the button to the coolvibes site work?

:question: :question:

^^^ This isn't helping....

I can see your request button in your blocks. This is an activity starter to a url. There is no reason why this should not work without the tasks extension.

Don't know what you mean about the coolvibes site. Do you mean the Play button ?

no theres another button that says coolvibes site
anyway the buttons won't work without the task extention

Then you must be using it somewhere

lol i'm not

cooljay1_copy.aia (1.4 MB)
have a look here in the blocks

I removed the Tasks extension, restarted AI2, tested with companion (android 13, real device).

Coolvibes site button works
Request button works

uh ok i'll try

alright that worked