Getting this error while running app server

I am getting this error while running java_dev_appserver --port=8888 --address= appengine/build/war/

CLOUDSDK_AUTH_OPT_OUT_GOOGLE_AUTH=False, CLOUDSDK_CORE_USER_OUTPUT_ENABLED=True}, workingDirectory=Optional[appengine\build\war], stdinSource=InputSource{kind=PROCESS}, stdoutSink=OutputSink{kind=JVM_OUT}, stderrSink=OutputSink{kind=JVM_ERR}, successCondition=ExitCodeSuccessCondition{exitCodes=[0]},$1@7085bdee}: CommandResult{exit code=1, stdout=, stderr=}
        ... 1 more

Any Help will be appreciated

Kindly show us full log so that we can see the errors that occured in the full process

Probably you need .exe or .sh .

java_dev_appserver is not a executable file is a console script both for Linux and Windows

If in command prompt (windows) you wont need any extension after java_dev_appserver
but in something like git bash you will need it :slight_smile:


Please post the full error log here so that we can help you further..

1 Like

Yes i tried to show the full log but it exceeds maximum word support


add a .txt file

1 Like

Sorry for late reply

Error.txt (35.5 KB)

Here is error code

Show the command u wrote

Here is the command

java_dev_appserver --port=8888 --address= appengine/build/war/

I suggest you to run ant clean for once and then recompile, then try this command

getting same error again

OK, Let me take a look at full log

Can you see in task manager is the java dev server is running or not ?

Not able to understand what you are saying

he means that terminal you use at the end of it do you see something like dev app server is running

@AkshatRana I get same error when I run java_dev_appserver --port=8888 --address= appengine/build/war/ when, it is already running in another window

I have a solution , try running this command java_dev_appserver --port=80 --address= appengine/build/war/ and then open https://localhost:80 in ur browser

This is not working

nooo.. you can also see in error.txt file

you have jdk 15 installed or some other version pls change to 8