Font problem and app closing

I have a problem with my app, and I didn't find the problem where.

In mouths before, I used a custom font in my project that I uploaded normally (without using an extension), after a couple of times, I re-opened my project, I didn't find the custom font and when I attempt to connect the companion I got the error showed in the picture.
I tried to build the app but it craches just after starting.

Help me plz

In all components where you had a non-standard font set, change it to another one and then back to the standard one.
This is a bug in AppInventor that I also noticed.

After deleting a font file from resources, the path to this font remains in the project. Only the font name is reset.

1 Like

think you it worked

This is how it will work. Just where you had the font from an external file, manually set a different font and then change it to the standard one. This will fix your project now, but in the future AppInventor will need to be fixed.

1 Like

Can you be clearer about what you mean by this? Particularly, "the path to this font remains in the project." The property editors should reset if you delete the associated asset.

After a custom font has been assigned to a button for example and then this font has been deleted from the assets, FontTypeface falls back to "default" and throws the posted error (without having assigned a font). This doesn't change when Companion is reloaded. You first have to assign a specific font again to fix the problem. You can then also select “default” again.

Just like Anka showed. The component still looks for the font in assets, but the font name is changed to "default". It turns out that the font name is reset, but the path to the font remains somewhere. Look at the image Anke showed, you can see where the component is looking for the default font.

Yes, the font property fields are filled correctly with the Default font. But the code still looks for the default font in the resources. Only manually selecting a different font and then returning to Default fixes the problem.