Firebase is not working!

Just tested with MIT firebase and all is working well.

If you are getting Permission Denied error, try dragging out the unauthenticate block and right click and Do It when in companion mode


then reload your project and it should work

1 Like

As @dora_paz said, it should look like this (→ Designer):


Post your settings.

And set the rules like this:


Can you tell me where to get the firebase token,URL and the project bucket so I can know wether I did it write.Also should I register like I am creating an app??

This guide will be helpful. It has all the steps needed to create a firebase database

I followed exactly what he said till step 9 but it shows no web API key

It gets generated once you go into the "Authentication" section for the first time

Go to Authentication, press get started

And then go again tp project settings and you will be able to see web api key

I got the API key followed all the steps in the above guide you sent.But it is not working what happens is when I run the app in emulator or AI companion it is flickering.I have attached image below how the emulator looks.It will flicker between that state in the image and the screen shown in screenshot of my inventor app continously.Also shows this error when I run the emulator.

Please remove call firebase.Unathenticate block


This block is used in only in specific cases


I deleted the the initialise part but this still happens.

Do you wish to post your aia to check it ? Also I do not see anything , you uploaded only sound

how should I do that

I am willing to do that but how should I post the aia

Export selected aia to computer, then press upload, add file from computer and hit upload

Sorry hope now your able to see.

Here is the air file you asked for.Thanks for your help till nowFirebase_testing.aia (2.1 KB)

I do not know if there is a glitch or something else. I noticed that the problem occurs if Database location is asia-southeast1 else if Database location is United States (us-central1) works fine. In attatched aia I used a test realtime database created in us-central and works fine

Firebase_testing_1.aia (2.6 KB)


Thank you for your help @dora_paz, now I see that the problem was in me choosing the Singapore server but when I chose the American server everything works fine.Thanks again for your help without you I could not have solved this problem.

1 Like

You are welcome, glad I could help :slight_smile:


It seems so ...

That will surely help many others as well.
Thank you for your persistence, Dora! :+1:

1 Like