Firebase Authentication server error


I was looking to add Firebase functionality to my app but I'm running into a problem where as soon as I set my Firebase database link into the properties i get a warning which I have made a screenshot of below. I have removed all authentication requirements from my Firebase database and it will still give me this error. Could anyone help me through this as I have no idea what the problem is.


1 Like

I have only seen this error on the Kodular distribution with their specific requirements for their Firebase component. If on App Inventor.....

You do not show your firebase component properties....assuming you are the firebase component.

You can hide the and a part of the Token/API Key, just need to see what is there, and does this all match your project settings on Firebase for your project?

should look like this:


Have you got your firebase project setup correctly on the console ?

Screenshot 2021-02-02 155126

Yup I've got the properties right and as far as I know the firebase setup too (im having it on the test mode where all read write properties are set to true).

Just checking, you changed the "Firebase Token" in the properties to the API Key from the firebase console?


I did not but now that I have changed it, it gives me new errors. First an error on initial opening of the app project and then another error when trying to save data to the database. It does seem to be connected to the Firebase now.


What is this:

If you are happy, I will run a couple of tests?

1 Like

Oh oops. Never mind I'll probably delete that database when this is sorted out. But in the meantime, sure you can do your tests. It'll probably help you help me :slight_smile:

Well that <projectID> is not responding.

I think the problem is at the Firebase end. Difficult to really know when in the dark....

Could deleting the entire firebase project help?

Might be good to start again, and work your way through the link I posted above, which shows all the stages.

Okay will try that. I will let you know what happens. Thanks for the help so far :slight_smile:

We will get it sorted out :slight_smile:

1 Like

I have made a new firebase project but I am hit with the exact same error I had before. The one which says I have to set my authentication server.

How annoying!

What shall we try next ?

I think I have found the solution!

I was creating projects on EU servers which has a tag that says its in beta mode. So I tried creating it in a US server and now it works.


Interesting. I note that I originally setup all my projects on Europe servers, but they are now all on US ones....

Well done for finding the solution, it should prove useful for others as well.


Yes thank you for the troubleshooting though. Without you I wouldn't have thought to start the project over again. :smile:

I have updated my guide to include this issue.

Thank you for finding it! :slight_smile: