Extension creating doubt

welcome to all especially extension developers, i am a extension developer
i am using


for a month for to use it in kodular,mit app inventor,i can develop but as others i am even sad about the 5 minutes time took,thus i switched to intellij IDEA i can create java file there

view the file above that is my code i know very well the code is correct

this code is in E:\my extensions\src\com\extensions\testtinydb

it was said many times in community to use Apache ant :ant: which is fastest way to develop it builds within a minute and so i downloaded its binary distribution
of version 1.9.15 release
this was uncompressed in C:\ and all the files inside it(bin,lib,etc,manual,...)are in C:\apache-ant-1.9.15

also my java folder which is jre1.8.0_271 is in C:\Program Files\Java

now i have to create,edit environment variables
i created a system environment variables as mentioned below

variable name:ANT_HOME,variable value: C:\apache-ant-1.9.15

variable name:JAVA_HOME,variable value: C:\Program Files\Java\jre1.8.0_271

now i edited the variable name: Path by joining
;%ANT_HOME%/bin at the end of my old value

now i am done i gave ok and went to my old java file path which is E:\my extensions\src\com\extensions\testtinydb and opened CMD there then i typed
ant there :sob: :sob: :sob: :sob: the result i got is

Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre1.8.0_271\lib\tools.jar Buildfile: build.xml does not exist! Build failed

now i am sure there is nothing wrong with ant all is at the java lib folder
which is C:\Program Files\Java\jre1.8.0_271\lib\
i went to the place and searched tools.jar which is not there now i don't understand where do i get it how do i get it some one please help i am already updated with latest java version explain what i need to do please :pray: :pray: :pray:

my pc is windows 7 -32 bit

@ewpatton please help


what do you mean by this, should i edit as you posted

Did you install "Java Development Kit"?

no i don't know how to install it, i have only java

i know
i think this is the link to install but i have windows 7-32 bit
that's my problem

1 Like
1 Like

yes i learnt and build that extension in the appybuilder code editor

i read that alderedy
as @shreyash said i typed java -version in my pc cmd
and i got this

java version "1.8.0_271"
Java(TM) SE Runtime Environment (build 1.8.0_271-b09)
Java HotSpot(TM) Client VM (build 25.271-b09, mixed mode)

is this means i have jdk or not

hope fully spending over 5 hrs i downloaded,setup jdk,now i understood i alderedy had jre,
but now one error gone,now the error is only on xml file

E:\my extensions\src\com\extensions\testtinydb>ant
Buildfile: build.xml does not exist!
Build failed

can you help @Anke :pray: :pray: :pray:

can some one help

You have been given all the help you need by Anke. Follow the tutorials.

It is not going to work with something on drive E that you installed on Drive C.
Best to have everything on Drive C, including your extension project.

You need to run ant from the top level of the project where the build.xml file is. You don't run it from a subdirectory. Try cd "\my extensions" and then run ant from there. I am assuming that my extensions is a checkout of the extension template repository. Also note that the App Inventor build scripts sometimes have trouble when there are spaces in the path. If you continue to encounter errors you may want to rename the my extensions folder to a different name without spaces.


Here is a simple how-to setup extension building environment. NO GIT, NO ANT, NO NEED TO DOWNLOAD MIT AI SOURCE CODE

It's in Chinese, you can translate it by Google, or here is the English version translated by Google.

actually my problem is i don't have the build.xml file is
when i PM a person he said that find it in

download it
but i can't understand it clearly

should i download this xml file

if yes then where should i place it

You are not reading the answers community members are giving you. As Evan explained, you are in the wrong directory. There is no need to download the build.xml file because you already have it. You need to run your commands from the root of your project directory. Follow the steps given by Evan, and everything should work.


thanks @ewpatton

all worked actually i didn't git clone the app inventor sources

after i did i did as you said all worked it came :star_struck: :star_struck: :star_struck:
thanks @Anke,@chrisward,@bartmathijssen,@kevinkun for helping

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.