Export a project as aia-file generates a .zip instead of an .aia suffix

When I try to export my project as an aia-file to my Windows-computer, it is stored with the suffix .zip.
See picture. I know, that an aia file is a zipped file, but in the past, aia files are stored with .aia suffix.
Is it my problem or an appinventor bug ?

afaik it is a browser setting...
which browser are you using?
try Firefox or Google Chrome...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.


I get this with Firefox:

My Standard-Browser is Firefox lastest Version 84.0.1 64 Bit, Windows 10 is up to date
I tried with Chrome > ok, aia File is generated
Firefox after internal reset about:support > zip File is generated
Uninstall Firefox and reinstall > zip File is generated, may be it is not trivial to delete Firefox up to the very last bit. i will work on that.

I have got exactly the same problem now, using Firefox 84.0 64b on Ubuntu Mate 20.04, installed dec 14 2020.

I uninstalled Firefox, deleted (maybe) all Firefox-profiles und reinstalled Firefox > .zip file is generated
I intalled and used Firefox-Portable > a .zip file is generated
I made a Windows 10 Reset for the Standard-Apps-Assignments > still a .zip file is generated.
I Used Linux-Mint 19.3. with Firefox 84.0.1 64 bit > a .zip file is generated

The Laptop of my wife with Windows 10 und Firefox 84.0.1 64Bit generates an .aia file !!!

It is a male - female problem with firefox :grinning:

I installed Firefox 83 from Firefox-Webpage (with new profile) > .aia file is generated
I made an update to 84.0.1 > .zip file is generated ( profile from 83 )

but not all 84.0.1 have the .zip problem, my windows 10 seems different from other windows 10
Firefox people should know the cause of the problem, i will tray to make a bug-report

No problems on all my PCs, notebooks ... (Windows 7 Prof, 10)

Firefox exports my projects as zip files, so whenever I need a aia, i log in to chrome and just export the project :grin:

1 Like

Same thing happens to me on both computers (windows 7 and windows 10). I also use Chrome to download aia :slight_smile:

Does the same thing happen also with Kodular?

Same on Kodular?

Yes same thing

1 Like


Durchsuchen → search

Same on Kodular

what should we search?

It looks like your files are associated with Win explorer by default..

Firefox has its own file handler, so please do check it first in Firefox settings, to start fresh you may also try by deleting/renaming the program handlers.json file in profile.
(I would prefer renaming the file)


the last folder might differ on your side..

Also make sure to reboot Firefox after any changes..

Edit: this is how it look in my handlers.json

"application/zip":{"action":2,"extensions":["zip","aia"],"handlers":[{"name":"7zFM.exe","path":"C:\\Program Files\\7-Zip\\7zFM.exe"}],"ask":true}

"application/x-zip":{"action":2,"handlers":[{"name":"7zFM.exe","path":"C:\\Program Files\\7-Zip\\7zFM.exe"}],"extensions":["aia","zip"],"ask":true}

Firefox ESR from Firefox-Webpage solved my .zip Problem . Now ist .aia again.

Thank you @Boban it works !

1 Like

German: Durchsuchen, English: Search