Error while connecting with android device through apk


First, I Tried connecting with an android device that was supported and i got to see a loading bar. The loading bar went up to 20% and then disappeared. The ''AI companion'' button was grey'd out so the phone was connected but nothing appeared on the phone's screen. After that i tried loading it with an android phone through an apk download but got an error that said this: "routing service filled with status 403 forbidden". I dont know if that phone was compatible. Does anyone know the fix to these please?


Hello dbz uni5

Not enough detail in your information. How are you connecting to the "Android Device"?

That error number fits at least two categories, HTTP and Lego Mindstorms. Your App may need to request an Android permission from the User.

That does not necessarily indicate a connection. More likely a failure. Note that when communications are involved, the Companion may not be suitable, you may need to run your App as an APK instead.

We need to know more detail:

  1. Make & Model of the devices
  2. What the App is supposed to do.

Show us your App Inventor Blocks:
Right-mouse in the Blocks work area and select "Download Blocks as image"

2 posts were split to a new topic: Changing Image Not Showing?


Thanks for your response. I'm sorry for the lack of information in my post, i'm pretty new to this whole thing. But here are my Inventor Blocks.

Once again thanks for your time and i'm sorry if anything isn't clear from me.


Is your api key from OpenRouteService correct ? Because The Navigate tool requires an api key not provided by App Inventor 2. Are those all your blocks?

Also have a look at


I've now implemented an api key from OpenRouteService. I first had an api key from Google but I've replaced it now. And yes, those were all of my blocks