Error when connecting to Companion


I am trying to make an app and test it in MIT App Inventor, but when I connect it to my android phone or my Chromebook with the MIT AI2 Companion to test the app, my android phone and Chromebook keeps on getting an error message saying, "MIT App Inventor is not responding." I tried testing it 10 more times on both my android phone and Chromebook, but it keeps on getting the same error message. Is this a bug in the MIT App Inventor system or something? This error message has not happened before.

Thank you

This sounds like a network connection issue, can you confirm that you have a good internet connection and that your device is on the same local network as your computer?

Yes, I have a strong internet connection.

But it is still not working, and I have tested other apps in the same network before and it worked.

Can you test one of these other apps again? Does it work ? If so then the issue may lie with your new app?

The other apps work, it's just the new app that has the error message.

OK, now we are getting somewhere :slight_smile:

Rather than ask a long list of questions, can you share your aia project here, someone can take a look.

It is best to test Bluetooth Apps as an APK. Also, include a Screen 'ErrorOccured' Block.

We need to see your Project file (.aia) to investigate the Companion Issue.

Since you are the only User to report this problem (out of about 400,000 Users this month), I'm moving your Topic to the Help section. The Title should relate to the problem: 'Error when connecting to Companion'.

When you name Components, leave the component type in the name as a prefix. This makes it much easier to understand the code.
For example:

'Wristband' would be 'BluetoothClient_Wristband'
'Motion_Sensor_Data' would be 'Label_MotionSensorData'

See my website for Tips and Tricks: