Error "The blocks area did not load properly" since Feb 3 Update

Previous to the February 3 update to AI2 my project (project name: "Fusion_Jan28) was opening without the error message. The apk that was built from that project is working fine on a tablet running Android 8.0.

I tried to open some previous files that were basically minor variants and they all failed with the same error.

I created new projects by importing various .aia files that were saved previous to Feb 3.
They all received the same error message.

I am totally lost on how to resolve the problem.

Help would be greatly appreciated.


Anybody have suggestions about the blocks area not loading properly? I see other people posting with the same issue.

Did you ever modify your code using one of the commercial coding with Blocks options? Mixing and matching compilers causes chaos.

You could post your aia and someone would check to see if they can run it. Something, like your isp, your virus checker etc. could be interfering with proper loading.

" basically minor variants " could have huge consequences.

Also, you could request here that someone at MIT look at your Project Fusion_Jan28 . This might take a while. Just post here you would permit MIT to look at your Project.

Thanks for your suggestions Steve.

I have never used anything other than MIT App Inventor to edit my projects.
As far as I can tell, nothing has changed with my isp or virus checker between the time everything was good and then not. I successfully created an apk on Feb 3 and when I next accessed my project on Feb 5 I experienced the issue.

I have tried using 2 different computers and will try later from a different network.

I have attached an aia. It would be great to see if someone can load it successfully.

I have previously ok’ed MIT to access any of my projects.

Thanks again.RecoveryJan28.aia (1.1 MB)

Doesn’t work here either. Are you aware you have multiple errors? See these

There may be more.

Fix them and your Project might load.

Hi Steve,

The apk generated fine on Feb 3. The errors showed up on Feb 5. I assume the errors are due to the blocks not loading completely.
I tried fixing the errors by adding the initialization blocks (etc) but the changes wouldn’t save.
I tried to delete all the blocks, save project, re-open and add some blocks - if I recall correctly, that still resulted in a block load error.
Thanks for the help.
I will “play” with this some more this afternoon.

I believe your existing project is corrupt.

Suggest - copy as many blocks as possible to backpack or download each set of blocks as a png, take notes on your layout, start with a new project, saving to aia as you go. See if it breaks.

I understand why your backup project isn’t loading. We’ll put together a fix.

Thank you Evan!!
Is it something that I have done that caused the issue?

No, this was a change on our end that introduced the problem.

For anyone experiencing this issue, we have deployed a potential fix on ai2-test. You can export your project from your account and import it there. Please let us know if it works (or not), so we can determine whether to deploy the fix to production.

I goofed up and failed to put all of the necessary changes on ai2-test. This has now been rectified. You will need to download yet another Companion. This new one is version 2.57t3.


Good news!
I exported 2 problem projects from my production accounts and imported them into ai2-test.
They both loaded without errors and function with the 2.57t3 companion.

Thanks so much!!

1 Like

I loaded my problem program to testing site. Everything OK in this test site.
But when I loaded this program to real mit app site again.
This program give block error again. ( Error is : The blocks area did
not load properly. Changes to the blocks for screen
6694392831803392_Screen1 will not be saved. )

Hello, today I had the same problem as reported in this post, none of my applications that contain long schedules can be opened, but when I loaded my problematic program on the test site everything is fine.
Hope you can fix this problem with a new update, I would really appreciate it. Thank you very much.

The test site and the main site are in sync. If you can share a project with us we can run an analysis on it to understand why it is failing to load.