Error on building MIT App Inventor - offline

i got following error on when i try to build mit app inventor on my pc windows 10

C:\Users\amd\Downloads\appinventor-sources-master\appinventor-sources-master\appinventor\build.xml:16: The following error occurred while executing this line:
C:\Users\amd\Downloads\appinventor-sources-master\appinventor-sources-master\appinventor\build-common.xml:299: The following error occurred while executing this line:
C:\Users\amd\Downloads\appinventor-sources-master\appinventor-sources-master\appinventor\blocklyeditor\build.xml:118: Java returned: 1

Total time: 20 seconds

Press any key to continue . . .

help !!

i just figure out my old error

now i got new error

C:\Users\amd\Downloads\Builder\appinventor-sources\appinventor\buildserver\build.xml:319: Java returned: 1

Total time: 20 seconds

i got this error when i run to server on my local host
command ~ ant RunLocalBuildServer

is this any problem at 319 line

is someone know how to solve these error ???


What java version do you have installed ?

C:\Users\amd>java -version
java version "1.8.0_301"
Java(TM) SE Runtime Environment (build 1.8.0_301-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.301-b09, mixed mode)


is these are correct version ??

i got some solution on community right now i am trying those
if i can run then i will close this topic as fast i can do

1 Like

ahh same error

C:\Users\amd\Desktop\MITBuilder\base\builder\appinventor\build.xml:16: The following error occurred while executing this line:
C:\Users\amd\Desktop\MITBuilder\base\builder\appinventor\build-common.xml:299: The following error occurred while executing this line:
C:\Users\amd\Desktop\MITBuilder\base\builder\appinventor\blocklyeditor\build.xml:118: Java returned: 1

Total time: 19 seconds

Press any key to continue . . .

my windows 10 spec

Device name	DESKTOP-605HOS6
Processor	AMD Ryzen 3 PRO 4350G with Radeon Graphics   3.80 GHz
Installed RAM	16.0 GB (13.9 GB usable)
System type	64-bit operating system, x64-based processor

when i try to run doctor

Diagnosing your system...

[PASS] Java is installed.
[PASS] Required version of Java is installed.
[PASS] Git is installed.
[PASS] Git submodules are properly set up.
[FAIL] Google Cloud SDK is not installed or not found on PATH.
_______Download gcloud from here:

Passed 4 checks and 1 failing

Press any key to continue . . .

please help !!

i just want to run on my pc for my use

i figure out by my self and solve the problem and now it working fine

thank you so much @dora_paz

Please share your solution so that it may help others....

the problem was with GCloud and i read the document of mit app but there is non thing mention
to make an auth with gcloud

so download gcloud > cmd run as admin > after it will take 2-3 min to setup and it will ask for " yes or no " select yes > it will open an page or copy the shown url in cmd > make an auth sign with google> it will ask for make an project in gcloud (here i am running on my pc so select "N" no)> it will install component app engine in cmd > after all done > just run build tool > run 7 and 8 for running on local host

ahh i spend whole day to make this work i hope someone will find this use full and it will save the time

1 Like

Note that this is only for deployment for production use. If you're just testing for development purposes, there is no need to set up everything in Google Cloud.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.