Error message "cannot find the component"

Hi, I am getting the following error message:
When I disable the block, the error message goes away.
I also use the same block on the first page, everything is fine there.

What am I doing wrong?

are there any errors on the screen?

what kind of component is Fragezeichen?
Drag a new component of that type into the working area
delete the old Fragezeichen and use the properties of that new component


Export your .aia file and upload it here.

The "Fragezeichen" is an image, and yes, I already removed it and replaced it with a new one.
The result is the same error-message.

The Timer: TimerInterval is 50, TimerEnabled = True, and TimerAlwaysFires= True..

When I disable the "Fragezeichen" Image, I get the error message for Image3.

Hard-refresh your browser via the shortcut Ctrl + Shift + R, exit the companion app, then connect again. If the problem still persists, you probably have a corrupted project. Follow ABG's guidance and post your project here.

Thank you very much.
Is there a way to solve the problem without having to rebuild it from scratch?
rechnen4.aia (6.6 MB)

Even tho I see you're using Clock Timer for animations on all of your screens only Addieran and kettenrechnen are affected by this.

Detached the animations blocks in timer and the error stopped, I would suggest using animation extension instead.

Try this one with Phase Extension

rechnen5.aia (6.7 MB)


Thanks, then I will change that to an animation Extensions.

Problem solved.

Regards: AK

You are not using AppInventor, but another derivative. Please ask in Kodular community instead, as this forum serves no support for other derivatives.