Error from Companion - undefined variable (irritants:yail/1)

I have successfully used the iOS app to run a soundboard-type app developed in App Inventor but one of my students followed a YouTube video and created a fidget spinner app that will not run on my Apple devices. The fidget spinner app runs fine on an Android tablet running the Companion App, but the iPad/iPhone screen glitches when I try to run it and I get the following error in App Inventor:

Hi @Simone_Ferdinand,

Would you mind either sharing the AIA here or sending it to us privately so we can test it?

Thank you! Here is the .aia file. I also tried the Introduction to Machine Learning: Image Classification app that is on the App Inventor website and got a Runtime Error.Fidget_Spinner_Game.aia (302.6 KB)

First - great news on your progress.

Second: tried IOS companion on 2 apps. Diff problems - the app in development caused error message ‘Error from Companion - undefined variable (irritants:yail/0) therefore similar problem prev report except that the yail/1 message is the yail/0 message for me.

The other app is one that was published in 2019 on Google Play. Screens not displaying in full and no selections showing on the listpickers.

Both are perfect on android

Hi @Enjayk,

If you send us the AIAs we can take a look. Please note that extensions are not supported on iOS right now, so if your app relies on extensions it will fail to initialize properly.


Ok. I've been investigating this one for a while now and I think I understand the underlying issue. I've temporarily fixed it in the app but it has revealed another problem that I'm now working to fix. This is going to result in two separate bugfixes that need to be submitted for review.


Thanks for your reply - files are here.S_HANDICAP_LEAGUE_MIT_test.aia (997.0 KB) B_HANDICAP_PUB_MIT_test.aia (504.9 KB)

S_ file is latest work (intend to publish during next week), B_ file was published on Google Play in 2019.

No extensions used, nothing fancy. Projects use very basic functions. I'm the naive developer, age 67 and a non-coder but finding your MIT AI service brilliant.

Thanks again

Thanks. I'll try these out and get back to you.

Ok. I believe I have a fix for this issue and have submitted a patch for review.


Thanks in advance.

Hope you're getting some free time

Hi Evan,

Thank you for looking into this and working to resolve the issues we raised. It is helpful to know that extensions are not supported on iOS for now - I will keep that in mind.


can I chip in on this thread please? I am attempting to create a project where a WebViewer loads p5js and Tone.js. I then use MIT App Inventor to call the various Javascript functions to play sound in the app.

It all works fine on Android, but runJavascript returns error irritants...

The project is here:



Yes, RunJavaScript isn't yet implemented on iOS. That should be making its way into the next version.

Evan, any update on the fix, approved?, released?

A gentle enquiry


The fix should be in the version for beta testing on Apple TestFlight, version 2.60.1 (2).

hi, Ewan, I have a very similar error.
I am using the version 2.60 (build8) in my iphone and I want to do the tutorial Look Extension - YouTube (in the description you can find the aia)

I get the following error:
Error from Companion: error: undefined variable. (irritants: yail/

Many thanks in advance

You cannot use extensions on AI2 for iOS.

If this should ever be possible, extensions would also have to be written in Swift and not in Java.

1 Like

Promixity_Sensor.aia (622.0 KB)
here's mine! Thank you, sir!

I´ve got similar problem, trying to use Machine Learning for Kids. It works on Android devices, but not on iPhones from me or my students. Can you help me in anyway?
Detector_Sentimientos3.aia (2.2 MB)

My understanding is that Machine Learning for Kids makes use of extensions, and we cannot support extensions in the iOS companion at this time.