Error for AI Companion

Dear all,

I was trying to connect my MIT application with my mobile phone through wifi by AI compmanion and after i scan the code and it reach 96% it stops and the gui does not appear ,

as per attached photo
Please help me in this problem please??

Did you select Legacy connection checkbox ?

It could have something to do with the size of your Project - we can see it is at the assets stage of the process.

Does your Project include images? If so, have you optimised them for Android?

See my list of potential "gotchas". Although aimed at building an APK, many of the issues listed apply to working with the Companion too.

ProfessorCad: Tips & Tricks Cannot Build/Install/Run APK

Hi sir, I have been working this project since 2 months and it is the first time to d it , just today it happended

Well, you may have added something to your Project since the last time it worked with the Companion? Either there is something wrong with that addition (an extra component or code) or you have increased the size of the Project (an extra image perhaps) or hit the size limit in terms of number of screens used (max is approx 10, but no App should need 10 Screens).

1 Like

We are also having trouble connecting to the iOS companions on apps that have worked before.


There are currently several issues with the MIT servers:

  • Companion for ios is not working.

  • Companion for Android does not work in Legacy mode for Androids but works without Legacy.

  • code.appinventor server is completely down. MIT is dealing with it.

MIT has been informed.


Check your anti-virus package to see if it has started scanning virtual devices.
The emulator is a virtual device.
Here is an example of one such interaction ...

1 Like

We are having the same issue at my school

Welcome PLTWTeach.

Thank you for letting us know. Please see #9.

MIT is still trying to fix the issues that are server related. When will it be fixed? As soon as possible; they are working the issue.

1 Like