Error en Clouddb

When I use the Clouddb component it gives me the following error: Clouddberror:
To what is due?
I use the default properties of the component
Thank you

If you are using your own cloudDB (redis server), particularly the one on redisLabs, you will have to untick the SSL box in the Designer.

To setup your own redis Server for CloudDB with SSL

The official MIT App Inventor services (e.g., and are configured to point to the MIT CloudDB service. The domain name in your error indicates that you’re using another service since is a placeholder in source files if an actual server isn’t configured.

You should only ask in the community of the builder you use.

Hello all
I have the same issue even if the SSL box in unticked. In my case, I use my own redis server in a VPS, and the connection the IP adress of my server, with port 6379 and a password. When I try to connect to my redis server with a ssh connection, it works fine. In AI, it fails. If you have an idea, please, tell us.

Have you opened up the port 6379 on your VPS firewall to allow external traffic ?

Also see here:

Yes, I did, exactly as explained in this link you gave us in your previous post (not the part with SSH):

I must look your last link, to see the difference and if I missed something.

Just to be sure: the Token is the password of the VPS server, is that right ? ... and not the redis password ? I tried with the two possibilities, and it doesn't work in both cases

Have you setup with SSL ? (Not clear from your first post...)

No, I didn't ... sorry ... SSl

SSI ???

The Token is the password you enter in the redis.conf: requirepass

SSL ... must be tired :slight_smile:

Ok for the pasword. But it doesn't work with this password too

By the way, in the two links, there is a slash missing before the redis-stable directory in this command:

$: sudo cp **/** redis-stable/utils/redis_init_script /etc/init.d/redis_6379

And the same error in the first link for this second copy command:

$:sudo cp **/** redis-stable/redis.conf /etc/redis/6379.conf

There isn't. you have joined the source and the target together for a copy command. this won't work.


cp /my/path/sourcefile.txt /newpath/newfile.txt

note the space between the two paths, subtle, but very important :wink:

In fact, there is a space between the two path, but it isn't much visible, but I edit my post to verify.

And what about the slash ? Without it, the directory couldn't be found, maybe because I wasn't in the ~ directory and and I needed an absolute path ...

Apart that, I checked everything in the second link and added the "save" that missed. Unfortunately, it doesn't work with that too ...

OK, I see what you are saying.

Fixed in the SSL version, cannot edit the Google groups one.

OK, thanks :).

After the redis-server command, I always have the same last line:
`16784:M 18 Apr 2021 10:48:44.925 # Could not create server TCP listening socket *:6379: bind: Address already in use

If someone can help ... I'm getting tired of that ...

Well, problem solved !

Thanks TIMAI2 for your help. In fact, I use a IONOS VPS too, and I had created firewall rules for connecting with AI2, but ... I missed to check this rules in the main board of my server ... At least I won't make this mistake again.

Good to hear. Means I got something right (today), in the documentation :wink:

You did :slight_smile: Really thank you ... so much time lost before you helped me ...

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.