Error: 908: The Permission WRITE_EXTERNAL_STORAGE has been denied. Please enable it in Settings App

Hi, I have been trying to save csv in specific folder in Documents, initially it occurred error 2104, and then now its Error 908. I have given app permissions and tried with Default Scope into App, Legacy and Shared. But still error is coming and its unable to store data in Documents. How to resolve this issue, can anyone help me in this..Thank You very much for your support.


Or this:


I have given legacy as default filescope and im testing on Android 11 Version

I'm talking about DefaultFileScope.
See the screenshot in post #2.


Yes as you said, i have given the same Default FileScope

It can read the Data from Documents folder in Android Phone, but unable to save data in it

Ok, so set it Legacy and try again.
And show you blocks.


make sure to use a filename which does not already exists


Here is a test app that allows you to save, read and share a text file (.txt, .csv etc.) in

  • one of the Shared folders (/Documents or /Download) or
  • the ASD or
  • the PrivateDir (internal storage).

This is possible on devices running Android 11+ without any storage permissions. On devices with Android ≥ 4.4 (API 19, KitKat) and ≤ 10 (API 29) WRITE permission is only required for the Shared folders. On all other devices (i.e. with Android below KitKat) READ and WRITE permissions are required for all storage locations except for the PrivateDir.

However, since WRITE permission automatically and implicitly grants READ as well, it is sufficient to simply request WRITE permission.

For this I modified Sunny's EFile extension a bit. @vknow360
Note: This is not possible using the File component.

So test this test app on different Android versions and give feedback if everything works as described here.


Great, but what changes have you done. :sweat_smile:

Only this:

Because the text file must be deleted after testing with Companion, otherwise it won't work with the APK, because then the text file was created by another app (Companion).

1 Like

These are the used components and extensions:


The TaifunSharing extension is only needed for the PrivateDir, because it doesn't work with the Sharing component. @Taifun

1 Like

Thank You for sharing, my problem got rectified.

1 Like

Fine, so also let the others know how you solved it (and if you did it with the File component).

I have been creating sub directory in the /Documents folder, as you mentioned in earlier post to some other person here, i removed the sub directory and saved directly in the /Documents folder...

But it should also work with a subfolder. However, this must first be created.

No idea, may be i have given wrong defaultfilescope, i have deleted everything and done from scratch following your instructions...And then i thought i should remove sub folder and try...It worked.

With the modified EFile extension it doesn't require WRITE permission (on Android 11+):


If you use the File component WRITE permission is requested.

OK...Thank You. I Will check with that one too...

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.