Error 404 when trying to create a route

Hello, I thought I would just write this here because I'm not sure what to do.
I am currently developing an app for a school project and I've hit a wall.

The app is basically based on a map where you travel to different spots and solve riddles following a story. I'm using the components Map, Navigation and LocationSensor.

The app sets your position every 10m and 1000ms and every time that happens an invisible marker teleports to you, then a route (red line) joins your current invisble marker with a set one. It used to work just fine but I tried the app recently and instead of creating the route, it gives back an error 404 and doesn't create the route.

If you have any ideas to help me I would appreciate them very much. :hugs:


Welcome kakobe.

Perhaps this recent discussion will be of value.

Do you have a copy of your aia that worked? Please try it and tell us if route renders.

In addition to the advice in the above thread in your instance there might be a timing issue of when your Marker coordinates post or are available to Navigate.

Also this behavior of your latest app version could be an ORS server error. ORS use 'donated' servers and when they get overloaded with calls from many users they sometimes are momentarily unavailable (for a few ms) .

Also this could be an issue with how you use the LocationSensor LocationChanged works. updating every second might be too fast for a LocationChanged event to occur or too fast to update the ORS server. Change 1000ms to something less frequent and let us know what happens. Perhaps 5000 or 20000?

Alright, I will try changing the update time. I think you're right and the error might have been due to the server.

I just tried it and It now works. Thank you so much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.