Error 1103: Unable to complete the given request with the text

I think this issue is different from Error 1103 - Unable to post or put.

It just said "Unable to complete the given request with the text"
I don't know what's wrong with my code;;

Please show/link to the api documentation

Is this: image correct ? Usually it is \n

You might also want to consider using:

@Juan_Antonio 's KIO4_Base64 extension

Also, I believe we implemented it so that when dictionaries are cast to strings they serialize as JSON, so rather than construct the JSON body you send to PostText using string joins you can build the body as a dictionary and let App Inventor do the work of stringifying for you.

Would be nice if it did, but for some apis and servers you have to write it out in text blocks, even though it appears to return the same output as a dictionary - I believe PostText sees an object rather than a string.

If you have a specific example you can point me to I can see what we can do.

There are several on the community, I will see if I can track one down...

I had same problem today, but after I disabled the "set Web.RequestHeaders", then it's working.

Same problem, I've disabled "set Web.RequestHeaders", but still error message 1103

Usually you get that message if there is no internet connection, see also

Try the example project together with your server App Inventor Tutorials and Examples: MySQL | Pura Vida Apps


i added a block like this, and problem solved


Thank You @Taifun

1 Like

I have got same error when open php file to retrieve data from table.
My problem solved using your block.