Emulator will not Load (TalkToMe) Project (in the emulator) (emulator installs but will not update)

Hello World

Our school uses MIT App Inventor as part of our curriculum, however, we cannot seem to load the project via the Android emulator function.

I have freshly installed AI Starter to my machine, of which I am an Administrator, and I have created a new project and placed some buttons on the screen for testing.

These are my steps:

We have checked the Firewall rules and there are no discrepancies. We have even let a test student account bypass the Firewall for testing purposes only and we have been able to replicate the issue then too. We have installed and reinstalled - no change.

Can someone please provide some advice?

Please note that I am from Melbourne, Australia and it is now term break. I may not be able to respond in 7 days' time but will get back to you when feasible.


Welcome Sarah.

My understanding / recollection is that Project will not work in the stock emulator. The emulator cannot 'emulate' shaking and sounds. If you notice, this advice is part of the tutorial: you can connect your
App Inventor project to your phone or tablet for live testing That is an indication the Project can only run using the Companion in live development using a real Android.

Does the Project run if you use Companion and a real device?


Hi Steve

Yes, according to the teacher of this class, an Android phone does work.

However, not all students have an Android device. We wouldn't recommend students using their personal devices for this scenario anyway.

I do recall that the emulator used to run - I have used it in the past.

How come there are issues now? What does the Runtime error mean?


Have you tried to use the emulator on a different project? One that doesn't use TextToSpeech control. Does a Project with out TTS run on the emulator?

I have never known the emulator to emulate TextToSpeech.

Sadly, I do not know. I don't think TextToSpeech ever worked in the emulator. I flagged this discussion for MIT, perhaps someone from there will comment. Perhaps @Susan_Lane could comment?

In the meanwhile perhaps you can get someone to donate an Android with an expired cell contract . An older device (devices without contracts do work using WIFI) that students could share since you "wouldn't recommend students using their personal devices for this scenario anyway."

I would just use a different Project because TalkToMe certainly is not working with your emulators down under.

Hi Steve

Thank you for your response.

Please note that the emulator does not work for ANY project, not just for TextToSpeech.

Projects do not load because we cannot do the update on the emulator - we are not prompted to update the emulator.

Please assist as this is impacting student learning.


Please wait for a response from MIT Sarah.

My emulator is broke too and will not update. It appears the emulator (at least for some users) is truly broken. Only MIT developers can resolve this.

A possibility in your case is port #8004 on your network is blocked. That is not my issue but your IT department might need to white list that port and/or allow anything with appinventor addresses.

The work around until they fix the emulator is to:

  • use real devices since that works
  • use a third party emulator
  • wait and hope

I hope to have a new test version of the new emulator available this week. If you're willing to give it a try, it would be valuable information on whether the new emulator works for you now that the old one does not.

I believe the current emulator does not support Text-to-Speech. I think the new one will, but this is something I haven't tested. I'll be sure that's looked at.

Hi Steve

We did unblock port 8004 and a few others to try to get it to work, however, it did not resolve the issue.

@Susan_Lane - that would be great if you can push the new version out so that the teacher and I can test it.

Please note that the TTS project was just an example - the class isn't using this functionality.


You can use NoxPlayer, it is a great Android Emulator that I have been using since early 2019 and it has shaking function and sound.

If the latest version runs slow or if you need the 4.4 KitKat emulator, you can use the April 2019 version.

Hi @Susan_Lane

Just touching base with you in regards to an update on the new emulator version.

Has there been any progress?

Looking forward to your response.


Hi @John_the_Lego

Thank you for the alternative.

I will be sure to pass this on to our teachers for review.


Testers are still reporting problems with the new emulator installer. I'm looking into it, but I don't have an ETA.

Where can I find the beta emulator?

Hi @Susan_Lane

Just touching base with you in regards to the emulator.

Have there been any updates?


Sorry Sarah, there have not been any updates. The last unsuccessful test was on July 14 when the testers uncovered multiple issues. The current new emulator is not yet usable.

  • Among other issues, there are problems with the proposed emulator installer that must be resolved.
  • The basic current emulator aiStarter installer is about 0.081 GB while this candidate is 2.5 GB .Susan is trying to make it more compact. She has not yet released another version of the 'new emulator' to those testing the new emulator.

When progress is made and the new emulator is available , the news will be posted here.

When will there be an updated emulator? Uncertain :cry: Be aware, this could come at any time but probably will not be released for a long time (my guess; Susan might comment when she is available).

but we have some other emulators like:

  1. Bluestacks

  2. Windows sub system for android (this works only for windows 11)

  3. MEmu player

and we have some android os can be installed on pc like:

  1. bliss os

  2. android x86

  3. remix os

  4. phoenix os

  5. prime os

but nox and MEmu player has good performances for an older systems :ok_hand: :+1:

You left out Genymotion, and the ability to run the companion as an app on Chromebooks.

1 Like

A suitable emulator to 'replace' the aiStarter emulator must be allowed in the school in this specific case. This causes 'usage' issues for student's PCs.

In particular Genymotion allows free usage for personal usage . With respect to classroom use

" 2.6 Other usage – Genymotion Desktop Non-profit organizations or Schools are allowed to use our Genymotion Desktop solution. With a presentation of a related document (company legal document, educational card), these licensees can benefit from a dedicated price." as stated in 2..6 at Conditions of use - Genymotion – Android Emulator for app testing

A working aiStarter is what most schools need in a classroom situation and Genymotion is probably not a solution for Sarah as are other emulators .not a practical solution vis a vis school policy. The school needs to apply for a special license.

Thanks every one for pointing out alternative emulators. Unfortunately they do not satisfy some school's requirements.

1 Like

Hi Steve

Thank you for the update - much appreciated.