Emulator Runtime Error message

In my class, we are trying to use the Emulator. My school district reimaged the lab and now I can not update the emulator software. Usually, when a user logs on to the computer and runs the emulator with AI Starter you get a message to update the emulator. Now we no longer get that message we get this giant Runtime Error.

I have reinstalled the software to the latest 2.3.0 restarted the computer and still the same message. Because of privacy, we are using the http://code.appinventor.mit.edu/ version of the software but even if I use the regular log-in version I get the same error. The phone app opens and it goes through the dialogue and we get this message

Not sure what to do.

Welcome Erik.

Sorry you are having issues with the emulator. You are not alone; MIT are aware of this problem and have a developer working on the issue. It will be fixed but perhaps not for a long time; perhaps MIT will comment.

Many developers, including myself are plagued with this identical issue. For us, the emulator is BROKE. The issue does not depend on whether you use the regular or code server; both provide the same white screen and refuse to update to the latest Companion.


Someone hopefully will soon post other ideas. What to do depends on your school IT and what they will permit.

For this particular error message, you should be able to initiate an update of the emulator by going to Help > Update the Companion. However, if the school is using a technology like Deep Freeze to roll back any changes made during the day, that will require doing this at the start of every class period. It might be better if the IT department did the update and then snapshotted the system so that it included the latest companion version for students.

Sorry, this doesn't work Evan and has been attempted by dozens of users as documented in the community. This behavior happens on non school networks too, and probably is also not possible for an IT group to fix either. You might like to discuss this with Susan.

At least two users have reported that it does work:

Just because some fixes don't work for some people does not imply that they don't work for everyone. There are multiple potential failure modes with the emulator.

When people see this particular error message where the package name com.google.appinventor.components.runtime is duplicated, it is because the emulator is running the old companion version 2.11a2, which predates App Inventor's support for extensions. If users get this message, they have successfully started the emulator and companion, so there is an active connection. At this point, an update should be possible using the procedure I outlined. In some circumstances, such as if the firewall configuration blocks outgoing connections from the emulator to the update server, then it will fail but with an error message related to network sockets typically. But we won't know if that's a problem until an update is attempted.

Thank you for the help. The Help--> Update companion did work thank you