Elements do not see in the list, only the first

I don't know if it makes sense to make an application that creates its own folder. From android11 it will not be possible and it is best to save the data immediately in the ASD directory or export it online to a Google sheet. Another way would be to store the data in TinyDB in the application memory and be able to export it to a file if necessary.

1 Like

hello, thanks for the information on android 11, I immediately put the advice into practice but with the "FILE" element I can't write on "Android / data /" + my folder, where am I wrong? I wish I could use "FILE" with the same path with both "ai companion" and compiled apk, sorry I'm at the beginning ...

I think @Anke could help with the new file read / write system. I am still confused with this and I do not have a new android for testing. Then, if you deal with enrollment in asd, we will advise you on the correct processing of your data.

You can use an extension that detects developer mode. Then build a block "if developer mode then link1, else link2.

See here:

1 Like

Can someone help? I have the same "Kio4 Explorer" and even if source and destination is correct,it can't copy files. I wrote here because I don't have access to ask anything on their google group.(I can delete files,create folders,etc.)

Show your (relevant) blocks.

I have Samsung galaxy tab 2 10.1 GTP5100(WIFI only model) for testing the app.And the program I wrote is copying the file I selected (It stores the file path in a textbox and also shows the path and it has the right path)and if I click paste,it pastes the file to kio4explorer's path.(The path updates every time when I afterpick in listpicker,otherwise you can't use the whole file explorer.(I can see the source and destination on my screen through textboxes and it shows the 2 path right.)
The problem is that the 2 path that the textboxes shows are correct,but nothing happens when I paste.
Unfortunately I can't really show my blocks,because I wrote a complicated app with lots of menu,more than 1screen(that communicates with each other through storeDB).

Show only the relevant blocks...

especially this. And let us know if you get any error message.


I have rooted device,so I don't need to start with "storage/emulated/0".
I don't have error messages,warnings or any java messages while app is running.

:question:

/sdcard/ is a symlink to /storage/emulated/0/


grafik

Shouldn't the "dest" be a complete path (containg the fileName)?

I switched them,but still the same issue.(Now the source has where I want to paste and the dest has the file that I want to copy.)

Make a small test app that reproduces this problem and post it (aia).

It tests only that block,and I copyed and pasted the directories and it changed the textbox's text to "copied", but when I checked,nothing was there.
KIOTEST.aia (12.0 KB)

No problem...

I tried to do the same way,but for me it's not working. I typed the 2 path the way I saw on the picture,but still not do anything.I can create folders and delete files/folders only.

Try this app:
KIOTEST_2.aia (76.2 KB)

and post a screenshot (after pressing Button1 and 2).


It has android 4.0.4.

This result doesn't make any sense at all:

grafik

Did you check if these files actually exist on your device (in /Download and /Pictures)?

Yes and it wasn't there.

Ahh, I didn't notice that. So you need READ_EXTERNAL_STORAGE permission on Android < 11, but it should be granted if you granted WRITE permission, because WRITE permission automatically grants READ permission (at least on Android < 11).