Download Multiple Files with subfolders

Try \r\n instead of \n.

Besides, instead of a split block, you can use a special block "csv table to list". You will find it in the blocks of the list.

Thats it, you made my day, thank you very much @Patryk_F


ok, last issue. This all works for API < 29, but I have learned that for API > 29, files can not be saved to a given directory, they have to be saved in the ASD directory.
So I changed it a little bit, but on my Google Pixel (Android 11), nothing happens

ok, first part (download) works now:


But the COPY part does not work:

This path //file/ will never exist.

See also here:


Does it really work? I don't think so, at least not with the compiled app (APK).

  • The ASD is created automatically on Android ≥ 10.
  • You cannot save / copy / download to the assets (//) and as I said this path: //files/ doesn't exist (and will never be created). So remove the .IsDevelopment and if_then_else blocks.
  • And move the join block to the global strPath


See also here:

Dear Anke,

it worked, but I changed it as you mentioned and Download still works.

However, path to the file looks like this:

BUT, the copy Function is still not working... :frowning:

So the Web component also adds the ASD path (like the File component):


automatically. Try this:

Same, download works (now with the correct path) but copy does not work

I think I know whats wrong:


fileName is the complete path , eg --> /storage/emulated/0/Android/data//files/files/file.pdf

so this:


Would lead to the following path:


Am I right?

So what would be the correct blocks?

Yes, the path is correct. But did you get an error message?

What do you get from the .Copied event?

No, the block / path is correct and should be:



leads to:


leads to:


It looks like the variable "fileName" is not the correct value. It contains the entire path to the file instead of just the filename.

and post the result.

Yes thats right!!

But how do I get only the filename and not the path?



The question is if this path / file exists. Check that.

This way you will get the file name along with the directory structure.

This did not work, but finally i got it working with this:


THANK YOU VERY MUCH @Anke and @Patryk_F