Double import possible

Yesterday i tried to import an aia. Because i was impatient I imported the same aia again while the first one was being imported. It resulted in this.

The projectnames are the same but they are seen as different projects. I can load one or the other and make changes. I still think it shouldn't be possible to import a project while one is already being imported.

This morning i tried to reproduce this behavior by importing large aia projectfiles but now I couldn't make it happen.

1 Like

Woo, seems a weird issue :thinking:

I tried your problem by starting a blank project named 'test'. Then, I exported it and imported it back to MIT App Inventor without deleting the old project. It showed a popup:
BTW, I use

It seems I was able to do it again.

Have you tested it on a test server? Because one of the fixes may have already made it out of the way.

I made the issue today. Didn't find anything that fit my problem. And no I didn't test it on the testserver.

Also possible on the testserver

This is really very strange.
This is not possible for me (not even on the test server):

Yes, I did it again with drag and drop. With a larger project that took a little longer to load. When I imported from the menu, I was able to import 2 times but the project was only one.

This doesn't happen when you make a new topic. This happens during importing an aia file.

I used aia files of about 8 MB. Importing the same file a couple of times without waiting for the import to finish could show the result.

I checked this on the test server (importing a 4 MB aia twice).
Result: Only 1 aia is imported.

I used 8 mb aia. Maybe yours was to small to make it happen.

Checked with 10 MB aia. Same result.

Oddly enough, they can be modified independently. Apk builds fine and they all have the same package name. Since everything works, why forbid the storage of projects with the same nave?

So you imported that other aia immediately after you pressed ok to import the first one?

I couldn't make it work with drag and drop. :grin:

Maybe 5-10 sec later.

I use Brave as a browser by the way. It is Chrome based so Chrome showed the same behavior. I tried with FireFox but i couldn't make it happen there.

I tested on chrome.

I also used Firefox when testing.
I'll try later Chrome ...

But apparently not many (including myself) have come up with this idea (since importing larger AIAs takes a long time anyway).