Display page html

I have a problem :-(, I don’t know what I did !!
I have my google sheet that I converted to csv, so far no problem. But when I try to display my page with the web viewer, it shows me the headers (A, B, C …) and the column numbers (1.2.3 …), why can’t i find out? I probably made a wrong manipulation at the googlesheet level but which one?
Thanks for reading.

  1. What does your “spreadsheetContent” look like? Does it contain all your data ?
  2. What does your ASLTable.html look like ?
  3. Review your Web1.Url, should look like this:

thanks for your reply, i checked there was an inversion with sheetid and sheetgid. but it did not improve the result.
I rewrote exactly the same code for the webwiever and it worked. weird
thanks again

I tried, it hasn’t changed. I am attaching a photo.

I save the page in HTML format in zip with the help of the goggle sheet menu and displays it with the help of the webviewer.

Please show your relevant blocks (webviewer etc.) and html file

My guess is the row and column labels are hard coded into your javascript in the html file ?

1 Like

yes i also think it’s hard. I have attached the code.

where is the html ?

hello, best wishes for this new year!
I advance in my project, I try to build the apk
everything works in dev mode, when I switch to apk, I no longer have my csv table, I have the html page: feuille.html, but the table is no longer there?
I tried different solutions, I changed the path of course as mentioned in Apk path, I put the taifun asset component, I think of something else but what?
Thanks for reading

Please show your relevant blocks (webviewer etc.) and html file

the webviewer is called “afficheur_web1”

Could it be that there is more than one feuille.html file on the device and the wrong file is loaded?

You need to call the webviewer in the Web1.GotText event block, there is no data until that point

1 ° for the file, I have not found where it is located?
2 ° for the displacement of the block I did, it did not work.
on the other hand I put a lablel on the response code, I have 400.
which means he can’t find anything? I believe
it would be in connection with 1 °?
thank you

I improved the precision on the errors.
I realized that the page that I display in my webviewer is not necessarily the last loaded. there are old pages left, however I delete the old one each time and reload the new one.
this is what i coded, i got error 400 not found!

thanks to all problem solved, the Spreadsheet Sheet GID went to zero, it worked and then there error?
finally resolved