Decimal numbers in a TableViewer

Good afternoon, I am reading information from a Google Sheets and displaying it using the TableViewer extension, but it is showing percentages with many decimals. Is there a way to format it to only show 2 decimals? Thank you in advance for your help.
I am attaching screenshots of the Google Sheets, blocks, and how it looks in the app.


Probably easiest to work on the actual data, than to try and modify in the table:





1 Like

Thank you very much dear, it looks great... I put the blocks to anchor the first row of the table in red, but when I scroll down it's not fixed, I don't know if I'm missing any block...

and your web gottext block ?

Sorry, I'm not familiar with those blocks, I'm just starting to get to know the tableviewer... where can I find them?

Well, you are using web Url and web Get ?

In the first post Web1_ResumenAsistencia.ObtuvoTexto is Web.GotText

Juan show us in text what you get, for example, in contenidoDeRespuesta.

That's right, I'm using web URL and web GET.

This works for me. I used a clock to simulate the web component gottext event.
Make sure that your list is "bigger" than your vertical arrangement, so that it will scroll.
It may help to put all your table settings together in the web gottext event

Dear, please copy your blocks to test and I can move up and down the list, but the table header (Student, Asi, Abs, %) doesn't stay fixed. It disappears as I scroll down. Can it be fixed or not? Also, I noticed that you leave spaces after some sentences (highlighted in yellow).

And I also see that in your blocks the information is horizontal, and mine is vertical...

This is how the blocks image is rendered when saved. Your blocks image is doing the same :wink:


I have just set the block to inline. Try it, right click on the block in the blocks editor and select inline inputs

Don't know why your list is not scrolling correctly. You can private message your aia to me and i can take a look.

How did I send you a private message with the 'aia'?

click his avatar, you will find button Message

I checked your aia,
you have a typo here:

the timer is not needed.

ps ps:

Resolved via PM. The OP's aia project has several nested arrangements and Screen1.Scrollable set, which prevented scrolling when in Landscape. Unchecking Screen1.Scrollable fixed the tableviewer scrolling when in Landscape.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.