De Blocks editor doesn't open anymore

Something is wrong there. I have my apps with a lot of blocks, but a .bky file is never nearly 10MB :flushed:
My blocks are 4MB and also about 7,000 blocks. But the project doesn't load either. I haven't worked with this project for a long time, but at one time there was no problem with opening the block screen. So I think the reason may be the new MIT servers. Or whatever update of the chromium caused it.

1 Like

Hello Patryk_F
the problem is not about me.
Something has happened at MIT appinventor in this last week.
Not just that screen, but any block a bit heavy, from any screen of any project, I can't open it.
I have removed all my projects from the platform.
I start a new project and when I load a block from my backpack, I can't even open it.
Right now in mitappinventor, I can't work, it's too slow.
I hope they find the problem soon


I checked 3 browsers. The problem is in Chrome and Edge. Firefox, as always, works for the best.

Try to empty your backpack and see what happens.

1 Like

I had tried everything. empty and fill the backpack, move blocks, recover old versions that worked well, everything and the system remained the same. After a few hours, without doing anything significant, everything has started to function again with apparent normality. I do not want to risk and I have followed your advice, I have started the project from scratch, simplifying blocks and minimizing code. It had taken months to do it and now it will take days to make it operational, but I don't risk working with a code that may be corrupt.
Thanks Peter

1 Like