D8 with jetifier

hi guys
hope you’re doing fine so
as i said here


i was trying to use both D8 and jetifier cause D8 makes the app smaller and jetifier helps me with convert the extensions to androidX
so i did everything but jetifier doesn’t start could anyone tell me how to fix this i tried many things but nothing works

any one please

anyone here got any idea please i’ve tried many things but none of them worked

Both of those branches are still works in progress. I would caution some patience as we work through all of the potential issues. If you want help, I would recommend giving some more useful information, such as any error messages or error codes that occur when jetifier execution fails.

@ewpatton hi
there’s no error messages but when i removed jetifier lines from DexExecTask and kept it in the ones in the compiler.java it gives an error
no such a method in DexExecTask
so i could call it from compiler.java but
it couldn’t start from DexExecTask side for some reason

hope anyone here can help please

Can you give full error and tell when it’s happening?
And also show what you have changed

@Krishjha07 well i stopped trying with jetifier so i can’t reproduce the error but it happened when i tried to build and i write the changes above

1 Like