CSV-Formatatted taking Info. from spreadsheet

Hi dear community,

Does any body knows why I am not able to see the info. in a listview? the app shows me the message:

As fara as I Know I need to allow permition in the spreadsheet , and I did it.



Even I follow the tutorial Metric RAT

https://docs.google.com/spreadsheets/d/1Cu77ER5zL6tieN6jQSpQAP0wtF8PNXvdCe6xmq_rZXc/gviz/tq?tqx=out:csv&tq=SELECT B WHERE A='selection'

when I run the URL in the browser it works


But in the code It doesn't show nothing

Does any body knows what is happening ?

what I want to achive is make filters after spninner selection

thanks in advance

Display the response content in a label to find out how it looks like...

The error message us telling you, that the list from csv table block failed... as it looks like an error because of quotes. .

quote in unquoted cell


ok, thaks for the explanation, by chance do you know how to fix it ?

the only thing that I want is to see the colums from the spreadsheet in a listview and make filters

give me a minut I will do it in a label and I return

I make the exercice in a lebel and I shows me the same thing

https://docs.google.com/spreadsheets/d/1Cu77ER5zL6tieN6jQSpQAP0wtF8PNXvdCe6xmq_rZXc/gviz/tq?tqx=out:csv&tq=SELECT B WHERE A='selection'


How can I fix it ?, please help

then tell us what is in label?

ok thanks

It show us this message

do you know what does that means? and how to fix it please

are these as your expected ? looks like there are errors when you retrieve data.

no, the informations need to show is this

something like this becase some words change the one who has accents, and when you put the url in the browser
https://docs.google.com/spreadsheets/d/1Cu77ER5zL6tieN6jQSpQAP0wtF8PNXvdCe6xmq_rZXc/gviz/tq?tqx=out:csv&tq=SELECT *
it shows the information but it doesn't do it in the app

It is working fine. Check this url


Show your block after picking the element from spinner

Also pls remove the remove from the list block.. As it doesnot retrun the header you no need to use that block, may be it may cause the effect.


Nice to know about you, I am go a head and check it, I go back in 5 min, thanks for the assistance

use DoIt on join block to check if the url is correct?

Very strange.. Your url returns like this.

Have you set any background colour?

this is because in the url you set the output format as html, not csv.

1 Like

no, any background color, and I run the URL that you provide me in a label and it is not working either, I will try now with the list view

Oh yeah. Correct @Kevinkun king . I have used the same web url. Now changed to csv and working good

Dear @Arturo pls show us your the block after picking the element from spinner

You are having the problem after picking the element so that it doesnt return csv formatted results

yes, It looks like, so let me run it with the correction and I go back in less than 5 min

unfrotunatly is not still working

I use this URL and this code



Here is the reason for your problem..

As i repeatedly pointed our in earlier post you failed to add the ' just before and after the get selection variable.. It should be like this.

haaa ok, I understand now, let me go a head and do it, and I return

so in this part of the code


afeter the where do I need to put the (') ? or not

and how can we know how to write this
in stead of select B where A = 'selection'

is there a way to know the translation?

Try like this

Nothing to change in the url.. Automatically your url will be decoded. Dont worry about %20 or %27 and all. Just add two places using mutator in join block and add empty string box in which you add the symbol (') in both textbox and test. You will succeed

ok , it works much better but you know why It shows only one header?

Thanks @Spicy_Topics or all the help that is almost donne

1 Like

Because you are calling only one Column (SELECT A.... ) and it contains only one header so..

If you want another col just add li like,