Corrupt File Structure, Corrupt Blocks, Cannot open .aia

I have an app that I have been working on for a couple months, and I call it the Legacy Companion App. All day yesterday, I had been working on the "Achievements" Screen, and I remember the chromebooks shortcuts being bad I believe I pasted the entire contents of my backpack at some point, but I didn't realize. When I come back to it later, I find an error saying, "The blocks area did not load properly. Changes to the blocks for screen 5249759880544256_Achievements will not be saved".

I looked throughout the Achievements screen and I find this block:

If only saving after was allowed because I believe those blocks were the source of the corruption.

I do not have any recent checkpoint of this project because that feature never seemed to work for this app, I cannot provide a blockview of the .aia because I deleted it off of MIT App Inventor, but I have

In my attempts to eradicate this error from my app, I found something really peculiar.
In the main directory of the aia, the files, ["youngandroidproject","src","Legacy_Companion","assets"] show.
I could not find any documentation on this, but from inspection the duplicate Legacy_Companion sub-folder appears to be a very outdated version of the app.
The .aia file is huge because of this duplicate, at 28.7MB
I tried many different ways to re-add this .aia to MIT including:

  • Swapping small sound files over the 4 song files to make the whole thing smaller
  • removing the achievements screen
  • editing specific blocks out of the .bky
  • reuploading copies of the app with different .zip parameters
    But I could never get it to actually reupload, for it would only hang and not do anything for extended periods of time or tell me it was not a valid .aia.

I know I have good internet so that is most likely not the problem.
I made a copy and tried to edit all the pasted blocks that I believe were associated with the corruption out of it's .bky but it told me the aia wasn't valid.
I believe the corruption is due to ListPicker1 blocks in the Achievements screen (for there are no ListPicker components in that scree)

Does anyone know a solution to this problem?

So a couple things.

I removed the duplicate copy of your project within your project. I'm not sure exactly how you caused that but that can cause a bunch of issues.

The error I encounter when loading the project is that there is a property called URL of a component called Custom_Download, however I don't see an extension providing this component. It's possible that you may have removed it at some point and the corresponding blocks were not correctly deleted. Obviously, App Inventor should handle this better in the case of a missing extension. The app could probably be amended to remove the offending blocks so that it will load again.

Oh, the Custom_Download was one of the components in my backpack that I pasted, would adding the component to the comps folder fix the loading error? Also thank you for fixing it :slight_smile:

This is the .aix for that extension:
yt.DeepHost.Custom_Download.aix (78.7 KB)

Adding blocks from the extension, which is not in the project, often damages the project. Also if someone updates his extension, removing one of the blocks, and you use this block in the project, the project will fail.

When I get home, I will attempt to add the aix to appinventor, and if it can't reload and putting it in the folder doesn't work I will reply back here.

Self-pasteing blocks from the backpack is a problem with the context menu that reacts to the right mouse button. It should not be so, I once reported this mistake, but will it be repaired, I do not know. Many errors were created by pasting blocks from the backpack.

1 Like

Are you able to link it here? I am having problems removing it myself

1 Like

I was able to open it up and resolve the error! This post can be resolved. Thank you so much.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.