Copy and paste with button in designer causes fault

When i copy a button in disigner the link to "" doesn't work anymore in blocks.

The new button needs its own click event block.

What happened to the click event block for the original button?

Did it get duplicated and cause a red flag for its duplicate status?
(I haven't tried this yet.)

I tried to duplicate this error unsuccessfully.

Can you show it to us?

Oke i found my problem when i tried to show it. Appinventor Copies also the link that already exists. I was not aware of this. When i made a new link i got a red cross. This is because it already existst. It copies also de code that was made in de parent link.
Thank you for your reaction and i am glad it isn't a fault of appinvantor. Sorry for the wrong interpretation.

I'm not sure I quite follow your description, but if you are concerned about the blocks being copied, you can hold the Shift key while pasting the button and App Inventor will only paste the design portion and not the code portion.

Thanks. This is a good advice for copying without the blocks.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.