"Contains" doesn't find a comma in a string where there is definitely one?

I have been working on my first app for some time now, always succeeded in getting through any problems with a bit of hit and miss but I'm struggling with this one.

I have a list of strings in a TinyDB. Those strings are now created by a join block, with 3 strings separated by comma :

I retrieve this list in another screen with Get and try to detect if in my list there are items with no commas, as in the former version of the app the tag in the TinyDB only had the first string in each item, and I want to convert this former list of strings to a new list of joined-with-commas strings.

The problem is : when I retrieve this list of joined strings in my other screen, I try to scan each item to see whether there are commas inside, and the "contains" block doesn't find any, even if there are commas in each item.

See :

For this example I fed only joined-with-commas (new format) strings into the TinyDB using the companion : two items, that you see in the Do it result of the GetValue block. But the "for each" block adds two empty commas at the tail of both items of the list, even if both do already contain commas.

I tried several checks : "ListeJuments" which receives the list of strings from TinyDb is indeed identified as a list ("test" for this turning true)
Each item of ListeJuments is correctly identified as a string ("test" for this turning true).
I tried a Do It with the first item of the list : "Buttercup,Horse,2005" which looks to me as definitely containing a comma.
But the "contains" block doesn't find the commas in this item ("Do it" for the "contains" block turning false)
I checked for a typo but can't find any. It's probably a format issue but each item is correctly identified as a string. How can contains not spot the comma in this string ?

Help ?

You have these round the wrong way


text should be item and piece should the comma

1 Like

You've mixed up the text and piece arguments. item should fill in the text argument while the comma should fill in the piece argument.

(from the App Inventor documentation)

1 Like

Oh dear, stupid mistake ! thanks a lot !

1 Like