Connection Issue

I have one student who cannot get connected to her tablet. She has all of her coding in place but when we try to connect it gets out to 92% and stops loading. We have tried different computers/tablets but have the same issue. So, I'm assuming it's something with her account, etc. In two classes of students, this one is the only one having this problem.

Suggestions would be greatly appreciated!

Try by exporting a project as .aia file.
Import the .aia into another account and check it it compiles there.

In case that works , then : -

  1. Export all her projects as .aia files
  2. Create a new account.
  3. Import all .aia files into new account.
  4. Bash on regardless !

Welcome Kelly.

The issue is probably an issue with her code. You can test this. Have her load a different project and see what happens. If the different Project loads, her issue is probably with her code, not her account. You tried different computers and tablets and the Project does not load.

Load her aia possibly on your tablet as recommended by @Anup_Ludra . I expect her Project still will not run. Why? We don't know, it could be because her aia file is very large, or she loads large image or sound files? How large is the Project aia? If you/she posts her aia file here, someone might look at it and provide specific advice.


I have a similar issue. I have been teaching w/ MIT App Inventor since 2015, so I thought I have seen everything. Here's what i have checked. In this case, after the QR code is detected by the AI Companion, nothing happens.

  • The computer (a fairly modern Mac) is on the same network as the Android tablet (though I know that shouldn't matter anymore).
  • She has reset everything (browser, AI Companion) many times and tried to reconnect to no avail.
  • We have downloaded her .AIA file and loaded it into my account and everything works fine.

I am kind of at the end of things to try. In my expereince, Macs just kinda work. Is there some piece of code that is a one-time install on Mac OS that she can maybe reinstall, or what? Changing accounts from her school account is not an option.


— dcp

1 Like

Just some thoughts:

Do you use her Android tablet when you test David? What Android version is she using?

to connect it gets out to 92% and stops loading . Is she on a school network or is she using a home router or a WIFI hub. If either of the latter, are others in her household using the home network to watch videos etc. simultaneously. What may be happening is the Project 'times out' due to a slow/shared network using the main App Inventor server.

If the second case, she may have a couple of options including using the alternative MIT Amazon server.


We used the same Lenovo Tab 4 8" w/ Android 8.1.0

She is on the school network — the same as the other 20 students in the room. And the connection does not load-and-hang (as described by the original poster), it just does nothing after the QR code is read. The QR code stays open on the browser and the AI Companion screen stays open on the tablet. Just nada.

The funny thing is that she has been using the same system all year... this just started happening last week.

I appreciate all advice. Thanks.

— dcp

1 Like
  • Do you get the same problem with a different aia project on the tablet ?
  • Has the tablet been shut down and restarted ?

Yes & yes. It seems to be something on her Mac. when she works with another laptop (either at home or school) all is normal. That's what I recommend she do, until we can identify a Mac-specific problem that would prevent connections.

— dcp