Connection error of bt connection



Vibsen (1).aia (210.7 KB)

M3.ino (2.6 KB)

Are you using a Mac?

See also here:

Using m5stickC board
hp laptop
No mac

what is your solution ?

same error


i can connect with other app light blue bluefrit
please give the solution..

Your app connects just fine to my micro:bit, and then it does not work because of the register... whatever that the micro:bit not has.
Anyway, the right way to do this is not to do the init in screen1.initialize, but in Screen1.permissionGranted first ask for bluetoothScan, and when that is granted, do the init.

same error
if its possible to give me screen shot solution..

Check if you have the latest version of the BLE extension. This seems to be it?


my version is 20230420 ..
please five me latest version link .
is it just update version it is enough ?
or recalling Bluetooth blocks?
please provide the feedback.
thank you .

I'm not sure, you're going to have to test this yourself (or someone else who knows will respond).

Somehow you get your error message when your device disconnects. I was able to recreate it by connecting to my micro:bit and then switch the micro:bit off.
I am not sure at all whether updating the extension will be enough. In any case try it.

And try to simplify your app. If you can, try to exchange strings, that is much simpler. And look at the iot section of this site for inspiration of how to simplify the connection process.

And which kind of Arduino are you connecting to?

1 Like

thank you for your feedback. i will try to connect as strings.

Not so fast! That is probably not the immediate problem.
The first thing to find out, did your device really connect before you get the error message?? If yes, did you get any error message about registering your UUIDs??
My impression is that the device decides to disconnect for some reason and therefore you get the error message.