Connect cam ip login

hello, I can find my cam page ( only a user password and password are needed, my webviewer does not display it to me, so I cannot access my ip cam. i'm probably missing something i tried a lot of things but i'm lost. thanks for your help

Your ip address is local so within your own network. You could try and test it within your own network with

http://username:password@ where you put your username and password in the right places and use your own ip adress.

thanks for your reply, this is not working.


What happens when you try the above? What happens if you try in a real browser.

on firefox it works I access the registry box (username / password) on my android companion nothing.

but the url like i send you doesn't work for you with your own username:password and ip adress?

yes yes I understood well I put mine :wink:

with the simple address I just have the webviewer which is black like the home page of the cam but no connection box

Here is in my browser the home page with the simple address (

with companion just a black screen, no display of the box.

I don't what format you software wants to see.

I tried all the possible formats according to the media port / http / https / rtsp / rtmp / onvif :frowning:

with activity it works but requires opening a browser, it's not practical because I have other cams

And to be sure, this app is working?

It seems you also have to set the port

yes the cam works, I can connect with the app, as well as with the simple address in my browser. there is just in my appfi inventor that it does not work, i must miss something?
I redirected port 9000 to 80 on my box

for your second proposal with onvif manager it works, but I don't know how to implement it in inventor !! :frowning:

It is just a url. You could try the example given in the topic complete with your data.

I put this address with my own data. the error returns me "web page not available ... net :: ERR_UNKNOWN_URL_SCHEME"
while this address is functional.

hello, I'm continuing my research. I found this. I put this address in my browser, but error. an idea ?
thank youSans titre

rtsp is not a protocol recognized by the webviewer. Maybe try with the customwebviewer from @vknow360.

CustomWebView : An extended form of Web Viewer

1 Like

Unfortunately CustomWebView also doesn't support that.
Only way to get it working is to redirect user to default video player app using Activity Starter.

1 Like