Names are important.
Your variable names lack the important vitamin 'Of'.
'index' might be renamed to 'indexOfQuestionInListAnswer' or
to 'indexOfResponseInCurrentQUestionsAnswers', or you might need extra variables with those names to keep them separate.
You are missing an important list block 'select item from list' in your 'if/then' test, maybe because you did not have the proper variable(s) to use in it.
Now would be a good time to go back into the Designer to rename:
Button5 to btnRetry
Button6 to btnNextQuestion
Label2 to lblTryAgain
(life is too short to have to read comments to figure out what ButtonNNN does.)
Names are important: