Companion not connecting

mit error

I can't connect it just gives me this error if I wait for a long time.

Hello @proJM, and welcome to the App Inventor Community! Before posting, please search for other topics related to yours to see if they can solve your problem.
Related posts can be found here: Search results for 'error 1103 companion' - MIT App Inventor Community

You also might want to try this, especially if you have bad internet.

Same here. broke my companion too from yesterday night Indian standard time. Felt like there was a deployment or something. (I noted the APK with QR code screen looks a bit different now. - That's the hint for the new deployment.) Also now I'm noticing the word "undefined" when I click ai companion in the popup. Been using this feature for years now.aicompanion_err_3_9_21

I do not know what this inscription "undefined" does, also occurs with me. But I tested now companion and works well.

Not sure if it's a trick but after seeing Patryk_F's comment I removed my companion from my phone, installed it from help->companion information. Tried with legacy connection checked once(while lead to AI2 web page crashing) and then upon relaunch, i'm able to connect using the companion.

Hope it works for others too.[the undefined word is still there though]. Could it be that our version had a hardcoded url that has changed and that's leading to comm failure?

The previous version you had was also installed from "Companion information" or from the Play Store?

I am using the version installed from the "Companion information" menu.

Maybe you had an old Companion version? v2.60?

Facing companion Stuck at 20% or companion Failed to connect ERROR,

it’s been more than an hour and still cannot to companion.

Hope Server ERROR, tried on different devices and networks

1 Like

Which browser do you use?

i’m experiencing issues if i use AI2 in desktop Chrome,Brave,Firefox.

If i use in iPad it works fine.


and then it says The Companion has disconnected

Tested 2023-11-04T11:43:00Z

Works only if Set Legacy Mode turned ON on Windows or Linux.

1 Like

What operating system version on your desktop?

Don't know what caused the issue as I'm using same method for years,
Turn on mobile hotspot and connect with PC,

but if I connect directly to wifi, it works fine, so this will be the solution

i have the same problem.i cant see legacy mode in my windows. it appears just in my you know any browser in windows to fix this?

Just Tick in Phone and connect Asusual,

It will be connected,

But Yesterday the issue is solved,

So you can try on normal mode also

This problem should be resolved...

1 Like