Companion Disconnection Issue - Seeking Assistance

Hello App Inventor Community,

I hope this message finds you well. I am encountering an issue with the App Inventor Companion where it consistently disconnects after a few seconds. This happens both with MIT App Inventor and Kodular Companion.

Issue Description:

  • Problem: The Companion displays "The Companion has disconnected" after a brief period of connection.
  • Attempts to Resolve: I have tried restarting the Companion app, restarting my device, checking Wi-Fi connectivity, updating the Companion app to the latest version, and clearing data/cache.

Additional Information:

  • Device: Samsung Galaxy S20 5G FE
  • Companion Version: 2.69
  • Connection Type: Wi-Fi

Steps Taken:

  1. Checked and ensured a stable Wi-Fi connection.
  2. Restarted the Companion app and my device.
  3. Updated the Companion app to the latest version.
  4. Cleared data/cache for the Companion app.
  5. Tried both MIT App Inventor and Kodular Companion with the same issue.

Request for Assistance: I am reaching out to the community to seek guidance on resolving this persistent issue. If anyone has faced a similar problem or has insights into potential solutions, your assistance would be greatly appreciated.

Note: I have attempted to find information on the status of App Inventor servers but haven't been successful. If anyone has information on server status or knows where to find it, please share.

Thank you in advance for your time and assistance!

(Canned Reply: ABG- Export & Upload .aia)
Export your .aia file and upload it here.

QRTags_copy.aia (1.5 KB)

I opened your project, and all I found was the bar code scanner (not external), and a button to ask for a scan.

I added a Label to catch the scan result, just in case.

Are you trying to run this in an emulator?

QRTags_ABG.aia (1.8 KB)

P.S. The Build servers are running fine, at low utilization.

You don't have enough in your app yet to need the Companion.