Companion Desconection at 20%

Seems thath now the Companion has disconnections at 20% (in normal builder server and iOs buider server).

Are you using the latest version of Chrome or Firefox? I haven't noticed any problem with companion in the latest Chrome.

I have the last versions Firefox.

I was running well with the this version. But now I have the disconnection Companions at 20%. The problem is happening from the last 30 minutes.

In Chrome happens the same:

I think this is a problem on the MIT servers.

I've been getting this too.

Although its more than just this - sometimes I'll scan the QR code, it goes away and nothing happens. Sometimes it stops at 20% and that's it. Sometimes it works until my app fully loads on the companion, then the companion crashes.

We did upgrade the TURN server earlier today. I don't know if the upgrade is a possible source of this issue or if there is something else going on, but we will take a look.


I just checked. Both the "ai2" and "code" servers work without any problems with the companion.

Check with a simple project.

A small project seems to work fine.

And transitioning to the erring project... it works?

Hello I am using a cell phone to connect to the AI Companion. At 15% I get 15 Rendezvous (please wait) then at 20% I get "20 Establishing Secure Connection" and then a 3rd pop up that states The Companion has disconnected. I have rebooted the cell phone and still getting the same issue. I have cleared the cookies in Google Chrome and still getting the same results. It seems like it works one day and not the next. Any ideas on how to get this corrected?

Yes, there is a thread for this already: Companion Desconection at 20% - #11 by busybird15

Can someone split/close the topic?

updated Chrome to latest build, now the issue again comes (companion disconnects @ 20%)

It happens for all projects in all MIT servers. May be you are ussing a different connectivity WebRTC for the Companion and don't need the TURN Server.

1 Like

the problem is solved ? :thinking:

no it's not...

Confirmed on iOS & Android with Firefox 115.4.0esr (but "Legacy" works), Chrome works.

In my versions don't work nothing. Not legacy and not chrome

Same. It was the same in my lab on Monday. Tried everything. I took a tablet (we use Fire tablets in our lab) home to connect to home network and same results. Just started working on Tuesday and Wednesday. Now..........:frowning: