Companion connection error - a silent death

Hi all,
I have allways problems with the companion (Samsung S7) Very often this happened:
doing some chane in the block or design section with the companion activated the connection Bt got lost:
But the companionis still going on to work with the old version before changing.
Reset connection - restart Companion - new connection and often the same message arrives even while loading the new connexion.
I work in my home network and there is no other stuff that may block my connection. other work fine.
It arrives on my laptop also on my desktop-computer. and with different apps, even very simple apps.

What can I do?

By the way, I wonder, why I seem to be the only one with this problem. I search for the topic companion connection error without result.

You are not alone Horst. Everyone occasionally gets the . Companion Connection Error State = disconnected message . Usually the user can just close the message and continue.

What can you do? Click OK
Also, if this is terribly annoying, you might use a USB connection instead of using Companion. It has been mentioned doing this might eliminate the Companion Connection Error State= disconnected message.

Try USB and let us know if that solution works for you.

MIT’s advice has been to use the Companion Legacy Connection. I have found that does not ameliorate . I suspect what is happening is your Android is momentarily losing its WIFI connection (but I do not know that for a fact).


Thanks Steve

What can you do? Click OK
I tried this. But the companion seems to work well, but I I call a doit or make a change in the block it will not work.

Try USB and let us know if that solution works for you.
I'll try

Tracking this as issue 2084.

Hi again,
Havn't much time to do work here, I come back. The problem is not really solved. But I can live with it charging again from time to time.
With USB the connection ist much more stable, but with the cable...
Now, suddenly, after connecting via WIFI since 2021-02-18 there is no connection anymore. After 1:44 min I got a error message:

I tried with two of my projekts working fine before.

I am suffering the same problem since yesterday.
I restarted both : Mobile and computer , but nothing changed and the problem persists

1 Like

We are looking into it now and are working on having the rendezvous service restored.

The rendezvous server has been rolled back and rebooted.
Try again.

The cause is the antivirus .
a window appeared on the screen of my computer and asked me if I agree to allow acess ..... I answered ( allow acess ) and my companion refunctioned without problems